Previous Thread
Next Thread
Print Thread
#12335 09/02/05 11:06 AM
Joined: Jul 2005
Posts: 177
J
Senior Member
OP Offline
Senior Member
J
Joined: Jul 2005
Posts: 177
Dammit.

I just got my brand new, "last run ever", "Actually looks like a gun", PC USB light gun, and I can't get it to work. Advice is appreciated.

I hooked it up to my OS9 machine upstairs by the bedrrom, and it won't even go to calibrate mode. But, on the first few clicks, I can see a couple of stray white lines. (running an old Rage Pro ATi Card, probably an interlace issue) Or... USB Overdrive shows no devices at all.

So, I took it down to my iBook in OSX, fired up the video out on my gateway 31 inch monitor in the den. Calibrate mode comes on in 800x600. Cool. Go to USB info on system profiler. There's the gun. Cool. Go to click... Screen flashes white... nothing. No click reported. No mouse movement. Install and look at USB Overdrive... device is there, but indicated as a type "other".

Argh. Pull up a few "known good" lightgun games, and nothing there either.

Anyone have any ideas or suggestions before I nag a friend with a PC into letting me try theirs? Is this something I might be able to talk the USB Overdrive guy into recognizing as a "mouse"? Or am I hosed?

Thanks,

Jon

Joined: Jul 2005
Posts: 177
J
Senior Member
OP Offline
Senior Member
J
Joined: Jul 2005
Posts: 177
Okay... Got a little farther.

Turns out it's recognized by USB Overdrive as a joystick, not a mouse. It sees both clicks, and tries to move the mouse around by registering it as offsets on the 4 joystick axis's.

When I go into the most recent build of MacMAME, it registers as a mouse. (If I aim and click middle right side, I can get "mouse y" about 60% of the time, and almost always get "mouse x" on middle top side shots. In the game, it just jumps from corner to corner.) But, no clicks. That's with USB Overdrive 10.4 on only. (USB Overdrive calls the clicks joystick buttons 1 and 2.)

When I use 0.66.2 in MacOSX, and I have USB Overdrive 10.4 set to abolute mode, I can get cursor movement which, while not being accurate, _is_ aligned with the gun. But, there are no clicks registered.

frown

The other bad thing is that the gun trigger is on a slide, and not a pivot pin. Stupid design. Just from the few hundred test fires, it's already kind of "dragging" as I pull unless I hold it just right. I might likely return it because of that, whether I get it working in MacMAME or not.

Jon


Link Copied to Clipboard
Who's Online Now
1 members (Dam0), 34 guests, and 3 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,881
Posts116,795
Members4,962
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com