Previous Thread
Next Thread
Print Thread
Page 1 of 4 1 2 3 4
#18051 07/19/04 10:45 PM
Joined: Aug 2003
Posts: 18
laurie Offline OP
Junior Member
OP Offline
Junior Member
Joined: Aug 2003
Posts: 18
Hey. Ive recently updated to panther and the open gl drivers are fixed. I can run all capcom and most snk games full screen 0 frame skip 60fps, only strange thing is that every 15 or so secs the frame rate will drop to 30 then go back up, as if there was something running in the background. I have looked in system profiler and cant see anything obvious, only finder and window driver etc. Is there anything else that could explain the problem.

Joined: Sep 2000
Posts: 286
Senior Member
Offline
Senior Member
Joined: Sep 2000
Posts: 286
Try switching from auto to manual frameskipping see if that helps.

Joined: Aug 2003
Posts: 18
laurie Offline OP
Junior Member
OP Offline
Junior Member
Joined: Aug 2003
Posts: 18
No no matter how high or low the frame skip is it still does it. It will run perfect at 0 frame skip but only for 15 secs at a time.

Joined: Jul 2000
Posts: 497
MacMAME Author
Offline
MacMAME Author
Joined: Jul 2000
Posts: 497
Quote:
Originally posted by laurie:
I have looked in system profiler and cant see anything obvious, only finder and window driver etc. Is there anything else that could explain the problem.
Do you have WindowShade and minimize in place? Safari (or another web browser) running? A window minimized to the dock?

Joined: Aug 2003
Posts: 18
laurie Offline OP
Junior Member
OP Offline
Junior Member
Joined: Aug 2003
Posts: 18
nothing minimized or running. It happens with software as well as open gl. Whats windoshade? :}

Joined: Sep 2000
Posts: 286
Senior Member
Offline
Senior Member
Joined: Sep 2000
Posts: 286
Make sure the MacMAME's Error log isn't running.
(run a game, hit ESC, look at the menus.)

Joined: Aug 2003
Posts: 18
laurie Offline OP
Junior Member
OP Offline
Junior Member
Joined: Aug 2003
Posts: 18
No error log is off. This is such a shame it runs so well except for this. Im only being fussy because im off to uni soon and will be selling most of my games collection, so I want to get mame running well to soften the blow.

Joined: Aug 2003
Posts: 18
laurie Offline OP
Junior Member
OP Offline
Junior Member
Joined: Aug 2003
Posts: 18
Im bumping this as I still have not fixed it. Anybody got any ideas?

Joined: Feb 2004
Posts: 312
A
Senior Member
Offline
Senior Member
A
Joined: Feb 2004
Posts: 312
What's your hardware (mac/gpu/display)?

One possible reason is that MacMAME doesn't capture the display in fullscreen mode. So other applications might continue to draw in the background, and the pageflip isn't as optimal as it could be.

Joined: Aug 2003
Posts: 18
laurie Offline OP
Junior Member
OP Offline
Junior Member
Joined: Aug 2003
Posts: 18
Im on a G4 Imac 15" lcd With 512 ram and a Geforce mx 2 30mb graphics card, (well chip I suppose)
I just dont understand it. Also running other apps in the background does not seem to make it any worse.

Page 1 of 4 1 2 3 4

Link Copied to Clipboard
Who's Online Now
2 members (Richard Bannister, 1 invisible), 23 guests, and 3 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics9,103
Posts119,274
Members5,019
Most Online890
Jan 17th, 2020
Our Sponsor
These forums are sponsored by Superior Solitaire, an ad-free card game collection for macOS and iOS. Download it today!

Superior Solitaire
Forum hosted by www.retrogamesformac.com