Previous Thread
Next Thread
Print Thread
#21302 10/24/04 04:21 AM
Joined: Oct 2004
Posts: 3
Junior Member
OP Offline
Junior Member
Joined: Oct 2004
Posts: 3
Great work. Not nearly as polished as I'd quite expected, but a bit earlier than anticipated too.

Anyway, I have yet to get AO2 to play anything RAR-compressed. I understand there are RAR3 handling bugs, but from what I hear any of those deliver error messages. Any SNES or Gen/MD RARs I've tried thus far, whether via drag-and-drop or File->Open cause AO2 to stall for a second or so and then quit unexpectedly. All files I've tried so far work fine in 1.5.1.

Is this just a potential manifestation of the RAR3 bug, or something that might go away after, say, a reboot, or something odd, perhaps particular to my system, that you could use more detail on?

#21303 10/24/04 04:56 AM
Joined: Dec 1969
Posts: 920
Likes: 3
R
Senior Member
Offline
Senior Member
R
Joined: Dec 1969
Posts: 920
Likes: 3
Are you on a version of Mac OS X 10.2? If so, look at your Console when this happens. Do you see the following:

dyld: /Applications/Audio Overload.app/Contents/MacOS/Audio Overload Undefined symbols:
/Applications/Audio Overload.app/Contents/MacOS/Audio Overload undefined reference to _strcasestr expected to be defined in /usr/lib/libSystem.B.dylib

I've a feeling AO actually requires 10.3...

#21304 10/24/04 05:17 AM
Joined: Dec 1969
Posts: 920
Likes: 3
R
Senior Member
Offline
Senior Member
R
Joined: Dec 1969
Posts: 920
Likes: 3
Okay, I've just seen your post on the MES board, and I reckon that AO does in fact require 10.3. I've added an error check for that on loading.

#21305 10/24/04 06:45 AM
Joined: Oct 2004
Posts: 3
Junior Member
OP Offline
Junior Member
Joined: Oct 2004
Posts: 3
'k. And for the sake of any other readers with a similar problem, as I also replied at Emuscene, AO2 is not in fact fully incompatible with 10.2- any individual song files play fine, as do NSFs and GBSs and likely other formats. Archives (rar, zip, gzip) just don't appear to work.

Hence, rather than simply keeping the program from loading for an older OS, I would advise/request just giving an error pop-up/disclaimer stating certain features won't work with the assurance that, as with other outdated software issues, you won't actually handle support/bugfixes explicitly related to pre-10.3 systems.

#21306 10/24/04 02:22 PM
Joined: Dec 1969
Posts: 920
Likes: 3
R
Senior Member
Offline
Senior Member
R
Joined: Dec 1969
Posts: 920
Likes: 3
I'm not releasing software that only works partially on a given OS. AO 2.0b2 and later will require 10.3. Sorry.


Moderated by  R. Belmont, Richard Bannister 

Link Copied to Clipboard
Who's Online Now
2 members (Justin, Golden Child), 53 guests, and 2 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics9,261
Posts121,259
Members5,064
Most Online1,283
Dec 21st, 2022
Our Sponsor
These forums are sponsored by Superior Solitaire, an ad-free card game collection for macOS and iOS. Download it today!

Superior Solitaire
Forum hosted by www.retrogamesformac.com