Previous Thread
Next Thread
Print Thread
Page 6 of 6 1 2 3 4 5 6
Joined: Jan 2006
Posts: 3,690
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,690
small note to point out that as of current git repo, MAME requires Xcode 7.x (and thus OSX >= 10.10.4) to compile on OSX due to some flags which are set by BGFX library which are not recognized by older clang.

not a big deal since update to 10.11 is free, but still worth a not for whoever is stuck for any reason to 10.10.3 (as I am for another couple of weeks)

Joined: Jun 2017
Posts: 9
D
Member
Offline
Member
D
Joined: Jun 2017
Posts: 9
Originally Posted by judge
OS X:
- Install latest Xcode
- Install latest SDL development libraries
- make TARGETOS=macosx
- Add BIGENDIAN=1 to the line above when building for a PowerMac system

[RB - updated PPC instructions]


hi judge , where i can find ppc instructions ?

Joined: Feb 2004
Posts: 2,275
Likes: 14
Very Senior Member
Offline
Very Senior Member
Joined: Feb 2004
Posts: 2,275
Likes: 14
PPC isn't really supported at this point, but the instructions for Snow Leopard may give you some guidance: http://docs.mamedev.org/initialsetup/compilingmame.html

Joined: Jun 2017
Posts: 9
D
Member
Offline
Member
D
Joined: Jun 2017
Posts: 9
Originally Posted by Vas Crabb
PPC isn't really supported at this point, but the instructions for Snow Leopard may give you some guidance: http://docs.mamedev.org/initialsetup/compilingmame.html

thanks i have already read this link frown make doesn't work for my ppc frown

Page 6 of 6 1 2 3 4 5 6

Moderated by  R. Belmont 

Link Copied to Clipboard
Who's Online Now
6 members (AJR, mfm005, Heihachi_73, 3 invisible), 44 guests, and 4 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,979
Posts117,944
Members5,003
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com