Previous Thread
Next Thread
Print Thread
Page 1 of 10 1 2 3 9 10
Audio Overload 2.0 is out #43334 07/30/08 06:44 PM
Joined: Dec 1969
Posts: 905
Richard Bannister Offline OP
Senior Member
OP Offline
Senior Member
Joined: Dec 1969
Posts: 905

Re: Audio Overload 2.0 is out [Re: Richard Bannister] #43335 07/30/08 07:27 PM
Joined: Mar 2001
Posts: 16,594
R
R. Belmont Online Content
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,594
A few release notes for the PC versions:

The Linux binaries were built with GCC 4.3 (stock Fedora 9) this time. AFAIK any GCC 4.x-based distro should be compatible, but let me know if you have shared library issues and I can rebuild with compat-gcc like the previous versions.

Both the Linux and Windows versions now add an icon to your system tray which you can right-click to get a popup menu and control things. This is arguably most useful on Linux with multiple desktops, but if you want to load up a playlist and hide AO on Windows it's handy there too.

Like the recent betas, the Windows versions are built with Visual Studio 2005 SP1. If you get a configuration or missing DLL error, you need to run Microsoft's installer for the updated MFC libraries: 32-bit or 64-bit.

Re: Audio Overload 2.0 is out [Re: R. Belmont] #43339 07/31/08 12:43 AM
Joined: Jun 2007
Posts: 107
B
Brass Offline
Senior Member
Offline
Senior Member
B
Joined: Jun 2007
Posts: 107
I did get a problem on Pclinuxos if you're interested:

ao: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ao)

libstdc++6-4.1.1-4pclos2007

Re: Audio Overload 2.0 is out [Re: Brass] #43345 07/31/08 06:52 PM
Joined: Mar 2001
Posts: 16,594
R
R. Belmont Online Content
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,594
Mmm, that's a glibc thing rather than a libgcc/libstdc++. Not sure compat-gcc will fix that but I'll post a test later. 32-bit?

Re: Audio Overload 2.0 is out [Re: R. Belmont] #43348 07/31/08 09:49 PM
Joined: Jun 2007
Posts: 107
B
Brass Offline
Senior Member
Offline
Senior Member
B
Joined: Jun 2007
Posts: 107
I believe that is part of libstdc++ not glibc. And yes, 32 bit.

Re: Audio Overload 2.0 is out [Re: Brass] #43358 08/01/08 11:30 AM
Joined: Oct 2004
Posts: 17
L
L66 Offline
Member
Offline
Member
L
Joined: Oct 2004
Posts: 17
Hello,

I'm unable to launch the Mac version. Console.app lists this error after double clicking AO:

Quote:
8/1/08 1:28:36 PM com.apple.launchd[73] ([0x0-0xcd6cd6].com.bannister.audiooverload[29434]) posix_spawnp("/Emulation/Audio Overload v2.0/Audio Overload.app/Contents/MacOS/Audio Overload", ...): Bad CPU type in executable
8/1/08 1:28:36 PM com.apple.launchd[73] ([0x0-0xcd6cd6].com.bannister.audiooverload[29434]) Exited with exit code: 1


I'm using an old PowerPC G4 Mac mini, OS 10.5.4. Audio Overload 2.0b9 still works fine. Is the G4 no longer supported?

Re: Audio Overload 2.0 is out [Re: L66] #43367 08/01/08 07:43 PM
Joined: Dec 1969
Posts: 905
Richard Bannister Offline OP
Senior Member
OP Offline
Senior Member
Joined: Dec 1969
Posts: 905
Ugh, possibly - this wasn't intentional though. I'm in Denmark for the weekend but I'll check it when I'm home (Monday afternoon) and release a new build if necessary.

Re: Audio Overload 2.0 is out [Re: Richard Bannister] #43378 08/02/08 12:11 AM
Joined: Aug 2008
Posts: 10
C
Christopher S. Offline
Member
Offline
Member
C
Joined: Aug 2008
Posts: 10
Hello, all. I seem to be experiencing a bit of a problem. Despite the news about the .DSF format now being supported (that's also mentioned in the download), I can't seem to get that working. I took a look at the channels and it appears that there is no .DSF channel in v.2.0. Now, I feel like I just downloaded a clone of v.2.0b9.

Anyone know what's up. I thought it'd be nice if u also had a test track of .DSF to show that it's supported (what came packaged was "Defloration.mod").

I came across a .DSF track labeled "soatest.DSF (apparently a test track of Skies of Arcadia). If you can find a solution to this problem, let me know.

I also found it kinda awkward you still have an image of 2.0b4 in the downloads area. I thought the page needed to have a more updated look, that's all.

I currently use Mac OSX 10.4.11

Re: Audio Overload 2.0 is out [Re: Christopher S.] #43379 08/02/08 12:48 AM
Joined: Mar 2001
Posts: 16,594
R
R. Belmont Online Content
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,594
There are not channel mutes for DSF yet, in part because there would be 64 of them and the driver does dynamic voice allocation so it'd be useless.

Please try this known good rip:

http://rbelmont.mameworld.info/testdsf.zip

(copy/paste the URL into your browser's address bar).

ETA2: I just tried some DSFs on my G5 tower (running 10.5.4) and they played fine, although it took a few seconds after clicking Play before they started.

Last edited by R. Belmont; 08/02/08 01:04 AM.
Re: Audio Overload 2.0 is out [Re: Christopher S.] #43387 08/02/08 06:01 AM
Joined: Dec 1969
Posts: 905
Richard Bannister Offline OP
Senior Member
OP Offline
Senior Member
Joined: Dec 1969
Posts: 905
Originally Posted By Christopher S.
Anyone know what's up. I thought it'd be nice if u also had a test track of .DSF to show that it's supported (what came packaged was "Defloration.mod").


I don't include copyrighted code in my downloads. This is a matter of policy.

Quote:
I also found it kinda awkward you still have an image of 2.0b4 in the downloads area. I thought the page needed to have a more updated look, that's all.


Eh, 2.0b4 on the Mac looks just the same as 2.0 final. I've not bothered changing the image but other than the number it looks the same.

Page 1 of 10 1 2 3 9 10

Moderated by  R. Belmont, Richard Bannister 

Who's Online Now
4 registered members (R. Belmont, hal3000, Praxis, 1 invisible), 48 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,818
Posts116,112
Members4,921
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.3