Previous Thread
Next Thread
Print Thread
Page 504 of 516 1 2 502 503 504 505 506 515 516
Re: SVN builds - new driver flood [Re: Anna Wu] #112122
01/10/18 05:00 AM
01/10/18 05:00 AM
Joined: Mar 2001
Posts: 16,005
USA
R
R. Belmont Offline
Very Senior Member
R. Belmont  Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,005
USA
Konami these days is pretty much only a gambling company. Here's Quick Pick 5 from the more distant past when that was a sideline. Colors are obviously wrong smile

[Linked Image]

Re: SVN builds - new driver flood [Re: Anna Wu] #112129
01/10/18 03:34 PM
01/10/18 03:34 PM
Joined: Mar 2015
Posts: 52
F
fulivi Offline
Member
fulivi  Offline
Member
F
Joined: Mar 2015
Posts: 52
Here is a couple of screenshots from hp2645a terminal emulation... for your '70s-style remote-data-entry enjoyment smile

[Linked Image]
[Linked Image]

Executable of space-invaders port is here (together with all ROM images): HP_2645A.zip

--F.Ulivi

Re: SVN builds - new driver flood [Re: fulivi] #112131
01/10/18 05:33 PM
01/10/18 05:33 PM
Joined: Jan 2011
Posts: 174
A
Al Kossow Offline
Senior Member
Al Kossow  Offline
Senior Member
A
Joined: Jan 2011
Posts: 174
Originally Posted by fulivi

Executable of space-invaders port is here (together with all ROM images): HP_2645A.zip

--F.Ulivi


two http:'s in the url

Re: SVN builds - new driver flood [Re: Anna Wu] #112143
01/11/18 03:24 AM
01/11/18 03:24 AM
Joined: Mar 2001
Posts: 16,005
USA
R
R. Belmont Offline
Very Senior Member
R. Belmont  Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,005
USA
Now we've got a full POST test and color. Trying to get the sprites going now.

[Linked Image]

Re: SVN builds - new driver flood [Re: Al Kossow] #112146
01/11/18 09:54 AM
01/11/18 09:54 AM
Joined: Mar 2015
Posts: 52
F
fulivi Offline
Member
fulivi  Offline
Member
F
Joined: Mar 2015
Posts: 52
Oops, sorry... it's not the 1st time I stumble in the "add link" dialog of the forum editor...
Hopefully this is the correct link: HP_2645A.zip
--F.Ulivi

Re: SVN builds - new driver flood [Re: Anna Wu] #112168
01/13/18 02:32 PM
01/13/18 02:32 PM
Joined: Mar 2001
Posts: 16,005
USA
R
R. Belmont Offline
Very Senior Member
R. Belmont  Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,005
USA
Getting very close to done now, sprites are working. (This title screen is made entirely of sprites, surprisingly).

[Linked Image]

Re: SVN builds - new driver flood [Re: crazyc] #112281
01/22/18 10:40 PM
01/22/18 10:40 PM
Joined: Jan 2012
Posts: 783
C
crazyc Offline
Senior Member
crazyc  Offline
Senior Member
C
Joined: Jan 2012
Posts: 783
Originally Posted by crazyc
Lemmings 2 works now but vertical scrolling is jerky.

I was looking at this today and found that UNZ does the same if the "CPU fullspeed" option is set. I'm not sure what it means though.

Edit: Seems like a bug in the game. It flips the buffers after writing to the crtc regs then draws the frame after next to the back buffer, which is still being displayed until the next vblank. I can't find any videos on the internet of this so I don't know how it looks on real hardware.

Last edited by crazyc; 01/22/18 11:28 PM.
Re: SVN builds - new driver flood [Re: Anna Wu] #112386
01/29/18 04:13 AM
01/29/18 04:13 AM
Joined: Jan 2012
Posts: 783
C
crazyc Offline
Senior Member
crazyc  Offline
Senior Member
C
Joined: Jan 2012
Posts: 783
[Linked Image]
Added VRAM write masking.

Re: SVN builds - new driver flood [Re: Anna Wu] #112397
01/29/18 05:06 PM
01/29/18 05:06 PM
Joined: May 2010
Posts: 81
R
r09 Offline
Member
r09  Offline
Member
R
Joined: May 2010
Posts: 81
Funny, I was looking at that yesterday and wondering why the hell the game was writing a bunch of 0x30 where the menus should be. I guess now I know...

Re: SVN builds - new driver flood [Re: r09] #112411
01/31/18 03:32 PM
01/31/18 03:32 PM
Joined: Jan 2012
Posts: 783
C
crazyc Offline
Senior Member
crazyc  Offline
Senior Member
C
Joined: Jan 2012
Posts: 783
Originally Posted by r09
Speaking of that, there is something that's been bugging me for a while: a lot of floppy-based games (mainly Alice Soft ones) don't boot because the floppy drives always fail to read the disk the first time they are accessed (and only the first time).

I've found that if I add "m_fdc->set_force_ready(true)" to machine_start it seems to solve that issue, but I haven't submitted that because I don't really understand the floppy system all that well, and I don't know if it's the "right" solution (as in, more or less accurate to real hardware).

Added a workaround for this. Brandish is weird, it tries to read sector 14 on an 8 sector per side image. I've seen copy protection like that before but the same image works on UNZ, maybe they watch for that and fake it?

Page 504 of 516 1 2 502 503 504 505 506 515 516

Who's Online Now
1 registered members (Duke), 62 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,575
Posts112,029
Members4,812
Most Online225
May 26th, 2014
Powered by UBB.threads™ PHP Forum Software 7.6.1.1
(Release build 20180111)
Page Time: 0.126s Queries: 14 (0.102s) Memory: 5.7354 MB (Peak: 5.9574 MB) Zlib enabled. Server Time: 2018-09-20 08:57:15 UTC