Previous Thread
Next Thread
Print Thread
Page 6 of 536 1 2 4 5 6 7 8 535 536
Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
SVN revision 3283

Nascom 1/Nascom 2

I am not able to load and run snapshots (.nas) on Nascom 1 emulation.
With Nascom 2 emulation I have no problems.

Also can it be, the tape emulation for both drivers is not finish yet ?
Because the tape control menu is not available.

Joined: Apr 2004
Posts: 1,555
J
Very Senior Member
Offline
Very Senior Member
J
Joined: Apr 2004
Posts: 1,555
The tape emulation for at least nascom1 is broken by the cassette device update.

Joined: Jan 2006
Posts: 3,690
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,690
it has also never worked as a real tape: it loaded bits directly from CAS to memory frown

however, the cassette device update had the nice side effect to bring up these regressions which will eventually be fixed.

Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
I have also a problem on windows gui.
Can not run
"-bios 1" or "-bios T1" = NASBUG1.T1 (original version)
"-bios 2" or "-bios T2" = NASBUG1.T2 (1978)
Even I select in Properties - Miscellanous - Bios - NasBug T1 or Nasbug T2
If i start the emulation it show me always Nasbug T4 (NASBUG 4).
The only way to start the right Bios is to run on command line.
As example: mess.exe nascom1 -bios T2


Last edited by Anna Wu; 09/18/08 10:46 AM.
Joined: Sep 2001
Posts: 534
F
Senior Member
Offline
Senior Member
F
Joined: Sep 2001
Posts: 534
Originally Posted By Justin
IMO there's not much point in having a driver enabled if we have no dump of it at all....


But with the core's ever-changing structures and validations we will be able to fix those when they are introduced and not when we somehow got a dump.

Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
SVN revision 3283

Microbee 56

Can not load (boot)disk images, get a crash.
Tested with gui and on command line.
With Nanowasp emulator no problems.

Last edited by Anna Wu; 09/18/08 11:56 AM.
Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
Some screenshots (not made by MESS) about old and new drivers for Eastern European Computers and Clones.
Some drivers are very new and not working at moment. So I not make shots.

Last edited by Anna Wu; 09/18/08 05:31 PM.
Joined: Apr 2004
Posts: 1,555
J
Very Senior Member
Offline
Very Senior Member
J
Joined: Apr 2004
Posts: 1,555
Originally Posted By Anna Wu
SVN revision 3283

Nascom 1/Nascom 2

I am not able to load and run snapshots (.nas) on Nascom 1 emulation.
With Nascom 2 emulation I have no problems.

Also can it be, the tape emulation for both drivers is not finish yet ?
Because the tape control menu is not available.


I just took a quick look at the nascom drivers. The cassette port seems to be connected to a part (a 6402 uart) which is not hooked up in the driver code. It looks like this may require a bit more work to get cassette support working again.


Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
Originally Posted By etabeta78
yep, you can also find a link to another lunar.wav file to be loaded in a different memory location. that one works as well.

unfortunately, the basic.wav coming with this second lunar.wav is not loaded correctly frown

I will try the mp3 one, and see if it works better (once converted to wav)

however, thanks Anna Wu, I would have never found those files without your successful report smile


I agree. It seems other emulators have the problem too.
Also tried to load the basic tape according to the original Apple Basic manual without success.


Last edited by Anna Wu; 09/18/08 09:10 PM.
Joined: Jun 2007
Posts: 34
F
Member
Offline
Member
F
Joined: Jun 2007
Posts: 34
About the Apple 3 software you could find some in this link:

[censored]

The server is from Apple Computer and should be right and legal. (No it's not - RB)

Last edited by R. Belmont; 09/19/08 12:25 PM.
Page 6 of 536 1 2 4 5 6 7 8 535 536

Link Copied to Clipboard
Who's Online Now
5 members (Reznor007, Pernod, Duke, Vas Crabb, 1 invisible), 27 guests, and 2 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,959
Posts117,759
Members4,994
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com