Previous Thread
Next Thread
Print Thread
Page 1 of 6 1 2 3 4 5 6
Sticky: How to compile SDLMAME! (Read me first!) #35138
10/29/07 03:48 PM
10/29/07 03:48 PM
Joined: Mar 2001
Posts: 16,058
USA
R
R. Belmont Offline OP
Very Senior Member
R. Belmont  Offline OP
Very Senior Member
R
Joined: Mar 2001
Posts: 16,058
USA
Like I said elsewhere, this thread is for people to post what needs to be done to compile SDLMAME on a base install of an OS or Linux distro. It is NOT for discussion or support - if you are unable to build SDLMAME with these instructions, please start a new thread!

To kick off, for Fedora 18/19/20:
Code:
yum install gcc gcc-c++ SDL-devel libXinerama-devel qt-devel expat-devel fontconfig-devel SDL_ttf SDL_ttf-devel


If you are using a joypad or joystick (including wired USB Xbox 360 controllers), you'll need to make sure those drivers are installed as well:
Code:
yum install kernel-modules-extra


Updated Dec, 2013: Updated for Fedora 20 and latest MAME/MESS.

Last edited by R. Belmont; 12/23/13 02:59 AM. Reason: 0.152 on F20 updates
Re: SDLMAME distro cookbook [Re: R. Belmont] #35140
10/29/07 04:17 PM
10/29/07 04:17 PM
Joined: Jul 2007
Posts: 24
P
play0r Offline
Member
play0r  Offline
Member
P
Joined: Jul 2007
Posts: 24
Ubuntu 11.10 (should also work for Kubuntu)
Code:
sudo apt-get install build-essential subversion libsdl1.2-dev libgtk2.0-dev libgconf2-dev libsdl-ttf2.0-dev 


For Ubuntu 12.10 make that:
Code:
sudo apt-get install build-essential subversion libsdl1.2-dev libgtk2.0-dev libgconf2-dev libsdl-ttf2.0-dev gcc-4.6 g++-4.6


And for 14.04 make that:
Code:
sudo apt-get install build-essential subversion libsdl1.2-dev libgtk2.0-dev libgconf2-dev libsdl-ttf2.0-dev gcc-4.6 g++-4.6
sudo apt-get install libqt4-*


On 12.10, for MAME versions 0.147u5 and later 12.10 will be auto-detected and it will prompt you to install gcc-4.6 and g++-4.6 if you haven't already. If you do have them installed, it will build automatically. For 0.147u4 and earlier, you must "make DISTRO=gcc46-generic".

I believe this should be all you need, if not please correct me.

play0r

[RB - updated July 2014 for 14.04 and latest MAME/MESS]

Last edited by R. Belmont; 07/15/14 06:07 AM.
Re: SDLMAME distro cookbook [Re: play0r] #35144
10/29/07 07:34 PM
10/29/07 07:34 PM
Joined: Apr 2004
Posts: 1,554
J
judge Offline
Very Senior Member
judge  Offline
Very Senior Member
J
Joined: Apr 2004
Posts: 1,554
OS X:
- Install latest Xcode
- Install latest SDL development libraries
- make TARGETOS=macosx
- Add BIGENDIAN=1 to the line above when building for a PowerMac system

[RB - updated PPC instructions]

Last edited by R. Belmont; 05/24/08 02:22 PM.
Re: SDLMAME distro cookbook [Re: belegdol] #35167
10/30/07 07:33 AM
10/30/07 07:33 AM
Joined: Apr 2004
Posts: 1,554
J
judge Offline
Very Senior Member
judge  Offline
Very Senior Member
J
Joined: Apr 2004
Posts: 1,554
For a FreeBSD system with an up to date ports tree:
- cd /usr/ports/emulators/sdlmame
- su
- make
- make install

That will automatically download, compile, and install sdlmame and all needed dependencies.

If you want to build from the latest u-update, make sure you have done the above at least once to get the needed dependencies and from there on it's just a matter of issuing the appropriate make commands.


Sadly enough, there doesn't seem to be a PBI for pcbsd yet for either sdlmame or sdlmess.

Last edited by judge; 10/30/07 09:09 AM.
Re: SDLMAME distro cookbook [Re: judge] #41551
05/24/08 02:32 PM
05/24/08 02:32 PM
Joined: Jun 2007
Posts: 223
B
billb Offline
Senior Member
billb  Offline
Senior Member
B
Joined: Jun 2007
Posts: 223
For Yellow Dog 6 (assuming Software Development checked during install)

Code:
yum install gcc SDL-devel expat-devel zlib-devel mesa-libGL-devel gtk2-devel GConf2-devel


Detailed instructions

Last edited by R. Belmont; 03/05/09 04:50 PM. Reason: fixed GL name as per Bill
Re: SDLMAME distro cookbook [Re: play0r] #43035
07/19/08 10:04 PM
07/19/08 10:04 PM
Joined: Feb 2007
Posts: 463
C
couriersud Offline
Senior Member
couriersud  Offline
Senior Member
C
Joined: Feb 2007
Posts: 463
Ubuntu 8.04 (Hardy Heron)
Code:
sudo apt-get install build-essential libsdl1.2-dev libgtk2.0-dev libxinerama-dev libgconf2-dev


Tested on a fresh install from the Live-CD.


Re: SDLMAME distro cookbook [Re: couriersud] #44100
08/26/08 02:12 AM
08/26/08 02:12 AM
Joined: Mar 2001
Posts: 16,058
USA
R
R. Belmont Offline OP
Very Senior Member
R. Belmont  Offline OP
Very Senior Member
R
Joined: Mar 2001
Posts: 16,058
USA
For Debian and friends with OSS4, you may not get sound using the default libsdl1.2debian-alsa package. Replacing it with libsdl1.2debian-oss and specifying the sound driver for SDLMAME as "dsp" should work. (Thanks Rhapsody!)

Re: SDLMAME distro cookbook [Re: R. Belmont] #44498
09/06/08 06:20 PM
09/06/08 06:20 PM
Joined: Dec 2006
Posts: 149
J
jrcmilanez Offline
Senior Member
jrcmilanez  Offline
Senior Member
J
Joined: Dec 2006
Posts: 149
For Mandriva users:

1 - install your system with development packages
2 - get libsdl-devel package via urpmi
3 - edit SDLMAME makefile with your requirements
4 - make!

Re: SDLMAME distro cookbook [Re: jrcmilanez] #45488
10/11/08 10:33 AM
10/11/08 10:33 AM
Joined: Sep 2006
Posts: 200
São José dos Campos, SP, Bra...
Cyberzinho Punk Offline
Senior Member
Cyberzinho Punk  Offline
Senior Member
Joined: Sep 2006
Posts: 200
São José dos Campos, SP, Bra...
For Slackware Linux users:

$ unzip sdlmamexxx.zip
$ cd ./sdlmamexxx
$ mcedit makefile //and edit for your requirements
$ make

Dependencies:

GConf (ftp://ftp.gnome.org/pub/GNOME/sources/GConf/)
ORBit2 (ftp://ftp.gnome.org/pub/GNOME/sources/ORBit2/)
intltool (ftp://ftp.gnome.org/pub/GNOME/sources/intltool/)

Last edited by R. Belmont; 11/10/08 05:46 PM. Reason: updated again

Sorry, my English is bad!
MAME for Slackware
Re: SDLMAME distro cookbook [Re: judge] #46678
12/05/08 01:20 AM
12/05/08 01:20 AM
Joined: Jul 2008
Posts: 73
France, Paris
E
ElBarto Offline
Member
ElBarto  Offline
Member
E
Joined: Jul 2008
Posts: 73
France, Paris
Originally Posted By judge
For a FreeBSD system with an up to date ports tree:
- cd /usr/ports/emulators/sdlmame
- su
- make
- make install

That will automatically download, compile, and install sdlmame and all needed dependencies.

If you want to build from the latest u-update, make sure you have done the above at least once to get the needed dependencies and from there on it's just a matter of issuing the appropriate make commands.


Sadly enough, there doesn't seem to be a PBI for pcbsd yet for either sdlmame or sdlmess.


I've updated the ports for sdlmame and sdlmess and also created a sdlmame-devel ports for u release.
They are not in the current ports-tree yet (I've opened PR but the original commiter seems dead ...).
Just get the tgz at http://distfiles.arcadebsd.org/ports rm the current directory and extract the new one.
I've removed the useless wrapper script and sdlmame and sdlmess use .mame and .mess respectively (sdlmame-devel use .mame-devel to avoid configuration problems).

Page 1 of 6 1 2 3 4 5 6

Moderated by  R. Belmont 

Who's Online Now
4 registered members (AntoPISA, Osso, 2 invisible), 28 guests, and 1 spider.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,600
Posts112,408
Members4,821
Most Online283
Oct 11th, 2018
Powered by UBB.threads™ PHP Forum Software 7.6.1.1
(Release build 20180111)
Page Time: 0.103s Queries: 15 (0.036s) Memory: 5.7273 MB (Peak: 5.9482 MB) Zlib enabled. Server Time: 2018-11-21 12:38:37 UTC