Previous Thread
Next Thread
Print Thread
Page 1 of 3 1 2 3
(SDL)MESS not detecting/refusing Playstation BIOS #49731 05/01/09 10:37 PM
Joined: May 2009
Posts: 7
S
socialSavant Offline OP
Member
OP Offline
Member
S
Joined: May 2009
Posts: 7
Hello,
I have spent the last 24hrs searching for on answer to why I get this output:
Click to reveal...
[mythtv@myrielle ~]$ ls -l /usr/share/mess/roms/ps-20a.*-rw-r--r-- 1 root root 524288 2009-05-01 03:17 /usr/share/mess/roms/ps-20a.bin
-rw-r--r-- 1 root root 237161 2009-05-01 03:46 /usr/share/mess/roms/ps-20a.zip

[mythtv@myrielle ~]$ echo "649895efd79d14790eabb362e94eb0622093dfb9 <-SHA1 as posted at http://mess.toseciso.org/mess:drivers:psx:psu" && sha1sum /usr/share/mess/roms/ps-20a.bin
649895efd79d14790eabb362e94eb0622093dfb9 <-SHA1 as posted at http://mess.toseciso.org/mess:drivers:psx:psu
649895efd79d14790eabb362e94eb0622093dfb9 /usr/share/mess/roms/ps-20a.bin

[mythtv@myrielle ~]$ mess -verifyroms psu
romset "psu" not found!

[mythtv@myrielle ~]$ mess psu -bios /usr/share/mess/roms/ps-20a.zip -verbose
Parsing mess.ini
Parsing mess.ini
Build version: 0.130 (Mar 13 2009)
Build architecure: SDLMAME_ARCH= DISTRO=generic
Build defines: SDLMAME_UNIX=1 SDLMAME_X11=1 SDLMAME_LINUX=1 LSB_FIRST=1 PTR64=1 NDEBUG=1
SDL/OpenGL defines: SDL_COMPILEDVERSION=1213 USE_OPENGL=1 USE_DISPATCH_GL=1
Compiler defines A: __GNUC__=4 __GNUC_MINOR__=3 __GNUC_PATCHLEVEL__=2 __VERSION__="4.3.2 20081105 (Red Hat 4.3.2-7)"
Compiler defines B: __amd64__=1 __x86_64__=1 __unix__=1
Compiler defines C: _FORTIFY_SOURCE=2 __USE_FORTIFY_LEVEL=2
SDL Device Driver : x11
SDL Monitor Dimensions: 1024 x 768
Using SDL single-window OpenGL driver (SDL 1.2)
Loaded opengl shared library: <default>
OpenGL: NVIDIA Corporation
OpenGL: GeForce 6150/PCI/SSE2
OpenGL: 2.1.2 NVIDIA 177.82
OpenGL: texture rectangle supported
OpenGL: non-power-of-2 textures supported (new method)
OpenGL: vertex buffer supported
OpenGL: pixel buffers supported
OpenGL: framebuffer object supported
OpenGL: GLSL supported, but disabled
OpenGL: max texture size 4096 x 4096
Keyboard: Start initialization
Input: Adding Kbd #1: System keyboard
Keyboard: Registered System keyboard
Keyboard: End initialization
Mouse: Start initialization
Input: Adding Mouse #1: System mouse
Mouse: Registered System mouse
Mouse: End initialization
Joystick: Start initialization
Joystick: End initialization
Audio initialized - driver: pulse, frequency: 48000, channels: 2, samples: 512
sdl_create_buffers: creating stream buffer of 57344 bytes
ouput: unable to open output notifier file /tmp/sdlmame_out
OpenGL: VBO supported
OpenGL: PBO supported
OpenGL: FBO supported
OpenGL: using vid filter: 1
/usr/share/mess/roms/ps-20a.zip: invalid bios
ps-20a.bin NOT FOUND
ERROR: required files are missing, the system cannot be run.
Ignoring MAME exception: ERROR: required files are missing, the system cannot be run.

[mythtv@myrielle ~]$ mess psu -bios /usr/share/mess/roms/ps-20a.bin
/usr/share/mess/roms/ps-20a.bin: invalid bios
ps-20a.bin NOT FOUND
ERROR: required files are missing, the system cannot be run.
Ignoring MAME exception: ERROR: required files are missing, the system cannot be run.


I just don't get it... I have searched these fora for an answer as well as via Google to little avail. I did find this post at CENSORED which is a SLOW loading site, so here's a quote from Xanas, the original poster:
Quote:
Mess uses the ps-20a.bin bios yet it doesn't appear to detect the bios found in this thread with that name. It doesn't appear to be a wrong file, filesize is exactly correct, etc.

I found this odd.

Has anyone been able to use these files with mess?

I know mess detects my snes bios which is in the same folder just fine.

I've tried leaving it unzipped and zipping it (though the snes works either way, so I don't think that's it...)
this command...

./mess -verifyroms
romset snes is good
romset snespal [snes] is good
2 romsets found, 2 were OK.
Shows what I'm referring to, and to show what's listed in the bios folder..

du -b /home/xanas/.mess/bios/*
524288 /home/xanas/.mess/bios/ps-20a.bin
238811 /home/xanas/.mess/bios/snes.zip

Anyone have any ideas? It doesn't even say the ps bios is bad, it just doesn't even seem to see it.

My sentiments EXACTLY! It would seem I am not the only one to have this problem. Other than that, though, I can't find a lick of documentation to help me out. So, anyone got some ideas here? Thanks for the help and let me know if you need more info.

--socialSavant

Last edited by R. Belmont; 05/01/09 11:41 PM. Reason: Yes, we love ROM site links
Re: (SDL)MESS not detecting/refusing Playstation BIOS [Re: socialSavant] #49732 05/01/09 11:01 PM
Joined: Apr 2006
Posts: 721
Tafoid Offline
Senior Member
Offline
Senior Member
Joined: Apr 2006
Posts: 721
As simple as possible - whatever MESS is looking for as needed files must be kept in a folder named for the driver itself, or a .ZIP container with the driver name as the filename.

For example:
snes.zip (snes)
tg16.zip (tg16)
nes.zip (nes)
psu.zip (psu)




Re: (SDL)MESS not detecting/refusing Playstation BIOS [Re: Tafoid] #49738 05/02/09 09:02 AM
Joined: Apr 2004
Posts: 1,554
J
judge Offline
Very Senior Member
Offline
Very Senior Member
J
Joined: Apr 2004
Posts: 1,554
For the psu driver your bios file should be named psu.zip. The -bios switch is used to select a different bios when a driver supports mulitple bioses (for different bios revisions for instance).

If you have your bios stored in a location different from what mess expect by default then you can use the -rompath switch to point it to the correct location.

To start the psu emulation you could do:
Code:
mess -rompath /usr/share/mess/roms psu


Where you must have a file /usr/share/mess/roms/psu.zip containing the ps-20a.bin file.


The defaults for the rompath can optionally be changed by setting it up in a mess.ini.


Re: (SDL)MESS not detecting/refusing Playstation BIOS [Re: judge] #49739 05/02/09 10:03 AM
Joined: May 2009
Posts: 7
S
socialSavant Offline OP
Member
OP Offline
Member
S
Joined: May 2009
Posts: 7
Holy Sh*t!
Now that makes some sense doesn't it! Thank you both, Tafoid and judge. I am sorry to make such a stink, but you have to admit... there really isn't much in the way of documentation on this subject. Maybe I am just spoiled by the enormous amount of MAN, INFO, Wiki, HOWTO, Guides, and so forth that are so prevelent in the *nix community, but I found it difficult to use commandline options that the program expected but never documented or explained!

I will name the Zip accordingly and get back to you one way or another. If all is well, then I will be picking your brains in order to fill the Wiki or create some *nix style docs so that others don't have to feel so ignorant.

Thanks again,
--socialSavant

Re: (SDL)MESS not detecting/refusing Playstation BIOS [Re: socialSavant] #49740 05/02/09 10:25 AM
Joined: May 2009
Posts: 7
S
socialSavant Offline OP
Member
OP Offline
Member
S
Joined: May 2009
Posts: 7
Ah well... ok...
I so appreciate the input fella's, but it seems that we still have a problem. Take a look:
Code:
[mythtv@myrielle ~]$ mess psu 
ps-20a.bin NOT FOUND
ERROR: required files are missing, the system cannot be run.
Ignoring MAME exception: ERROR: required files are missing, the system cannot be run.

That was my first attempt.
Code:
[mythtv@myrielle ~]$ mess -verifyroms psu
romset psu [psj] is good
1 romsets found, 1 were OK.

That was a test which I expected to see something like, "21 romsets found, * were OK." Because there are 21 BIOS'es in said file. All of which have been tested previously and should garner no reason for failing at this time! But OK, at least one worked right?!
Code:
[mythtv@myrielle ~]$ mess psj
ps-10j.bin NOT FOUND
ERROR: required files are missing, the system cannot be run.
Ignoring MAME exception: ERROR: required files are missing, the system cannot be run.

This is what I got when atteempting to use said "OK" rom!

So now what?! Once again, I apologize if I come off ignorant or angry... but I am a bit of both... so what do you have in mind?

Thanks for the effort,
--socialSavant

Last edited by socialSavant; 05/02/09 10:31 AM.
Re: (SDL)MESS not detecting/refusing Playstation B [Re: socialSavant] #49741 05/02/09 11:12 AM
Joined: Jan 2006
Posts: 3,687
etabeta78 Offline
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,687
Wait a moment before getting angry wink

The psj you see between square brackets, means only that psu is a clone of psj (i.e. you might put psu.zip files into psj.zip if you want, but it is not related with the issue you're experiencing so let's leave it aside for the moment), not that psj is ok as well

In your case, the output of -verifyroms means that psu is ok (and it tells you that 1 romset is good because it treats psu.zip as a single entity, not as many different files). the strange thing is that it should not give you that error when you launch MESS afterwards...

The only possibility I see is that there is some name or checksum conflict in you BIOS

Let's try one more test: move out your zipfile from roms/, extract ps-20a.bin and rezip it (alone) into a new psu.zip file inside roms/. Then try again both -verifyroms and to run the system in MESS and post the outputs...

I think we will be able to understand a bit more what's going on with these info smile


p.s. about docs: I'm going to add a user manual to mess wiki very soon. it is far from being complete ot perfect but it could be a starting point for common issues... be patient a little more wink

Re: (SDL)MESS not detecting/refusing Playstation B [Re: etabeta78] #49747 05/02/09 07:04 PM
Joined: May 2004
Posts: 907
D
Duke Online Content
Senior Member
Online Content
Senior Member
D
Joined: May 2004
Posts: 907
Make sure you are not using 7zip to zip the files, MESS has trouble loading those.

Re: (SDL)MESS not detecting/refusing Playstation B [Re: Duke] #49756 05/02/09 11:04 PM
Joined: Jan 2006
Posts: 3,687
etabeta78 Offline
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,687
Originally Posted By Duke
Make sure you are not using 7zip to zip the files, MESS does not (and will not) load those.


fixed wink

Re: (SDL)MESS not detecting/refusing Playstation B [Re: etabeta78] #49757 05/03/09 12:44 AM
Joined: Mar 2005
Posts: 502
incog Offline
Senior Member
Offline
Senior Member
Joined: Mar 2005
Posts: 502
MESS Playstation emulation also doesn't handle CD's yet, I think it still runs Net Yaroze exe's though.

Re: (SDL)MESS not detecting/refusing Playstation B [Re: incog] #49758 05/03/09 01:00 AM
Joined: Mar 2001
Posts: 16,575
R
R. Belmont Online Content
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,575
Yeah, it'll load Yaroze exes, CPEs from the compiler, and PSFs (but the SPU emulation's bad - use AO instead) smile

Page 1 of 3 1 2 3

Who's Online Now
1 registered members (Fake Shemp), 47 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,811
Posts115,965
Members4,914
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.3