Previous Thread
Next Thread
Print Thread
Macintosh OS X OpenGL Experience™ #50881
06/17/09 09:07 AM
06/17/09 09:07 AM
Joined: Sep 2006
Posts: 89
M
M. Twitty Offline OP
Member
M. Twitty  Offline OP
Member
M
Joined: Sep 2006
Posts: 89
RB or anyone, is there any way you're aware of to correct the half screen videodisc playback under opengl on an iMac with an X1600 card?

I'd be willing to take semi-extraordinary steps to get it working, but so far I haven't been able to figure it out, and my search for a solution has come up empty.

Thanks in advance.

Re: Macintosh OS X OpenGL Experience™ [Re: M. Twitty] #50886
06/17/09 01:32 PM
06/17/09 01:32 PM
Joined: Mar 2001
Posts: 16,231
USA
R
R. Belmont Online content
Very Senior Member
R. Belmont  Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,231
USA
Err, I disabled the APPLE YUV path ages ago and everyone agreed it fixed the problem? Does -video soft work?

Re: Macintosh OS X OpenGL Experience™ [Re: R. Belmont] #50893
06/18/09 02:55 AM
06/18/09 02:55 AM
Joined: Sep 2006
Posts: 89
M
M. Twitty Offline OP
Member
M. Twitty  Offline OP
Member
M
Joined: Sep 2006
Posts: 89
-video soft displays the video correctly, albeit at about 1/10 speed. -video opengl displays the video at full speed, but only fills the left half of the screen.

The only LD game I have is Cube Quest, and I only noticed this problem when it was released. I posted about this a couple of months ago, but it wasn't critical at the time because I had access to a Windows box where it worked. But that box got repurposed into a server when my old server died.

Re: Macintosh OS X OpenGL Experience™ [Re: M. Twitty] #50963
06/20/09 03:35 AM
06/20/09 03:35 AM
Joined: Sep 2006
Posts: 89
M
M. Twitty Offline OP
Member
M. Twitty  Offline OP
Member
M
Joined: Sep 2006
Posts: 89
Is there a version that has LD support which still had the YUV path enabled that I can use to test this? I have sources back to forever...

Thanks.

Re: Macintosh OS X OpenGL Experience™ [Re: M. Twitty] #50990
06/20/09 11:55 PM
06/20/09 11:55 PM
Joined: Sep 2000
Posts: 202
DC, USA
W
will Offline
Senior Member
will  Offline
Senior Member
W
Joined: Sep 2000
Posts: 202
DC, USA
Twitty, how about if you edit your mame.ini and change gl_vbo to 0 ?

See if that works. With APPLE YUV enabled, my Mac Pro with NVIDIA GeForce 8800 GT card didn't produce any OpenGL video at all for Cube Quest. With YUV disabled, it works fine both on my MacBook Pro ATI Mobility Radeon X1600 and the Mac Pro.

Not sure what's up with your iMac. Which OS are you running? I'm on 10.5.7. Have you done all the appropriate EFI, SMC and graphics firmware updates?


=will=
Re: Macintosh OS X OpenGL Experience™ [Re: will] #50995
06/21/09 03:33 AM
06/21/09 03:33 AM
Joined: Sep 2006
Posts: 89
M
M. Twitty Offline OP
Member
M. Twitty  Offline OP
Member
M
Joined: Sep 2006
Posts: 89
Tried gl_vbo 0 and I still get half-screen video.

My iMac is a white 20", 2.33GHz, core2duo running 10.5.7 with every available firmware update applied.

Thanks for the suggestion. I'll keep banging on it, and welcome any more advice (besides getting a new computer, of course).

Re: Macintosh OS X OpenGL Experience™ [Re: M. Twitty] #50998
06/21/09 03:45 AM
06/21/09 03:45 AM
Joined: Feb 2004
Posts: 2,051
Sydney, Australia
Vas Crabb Offline
Very Senior Member
Vas Crabb  Offline
Very Senior Member
Joined: Feb 2004
Posts: 2,051
Sydney, Australia
try turning off PBO

Re: Macintosh OS X OpenGL Experience™ [Re: Vas Crabb] #51005
06/21/09 06:39 AM
06/21/09 06:39 AM
Joined: Mar 2001
Posts: 16,231
USA
R
R. Belmont Online content
Very Senior Member
R. Belmont  Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,231
USA
Will: that was because NVidia cards don't support APPLE_YUV, only ATI does.

Re: Macintosh OS X OpenGL Experience™ [Re: R. Belmont] #51111
06/24/09 01:58 AM
06/24/09 01:58 AM
Joined: Sep 2006
Posts: 89
M
M. Twitty Offline OP
Member
M. Twitty  Offline OP
Member
M
Joined: Sep 2006
Posts: 89
Duh.

Prescale must be set to 1. I never use glsl and didn't think of prescale until I set glsl 1 and got the "OpenGL: GLSL supported, but disabled due to: prescale !=1" message.

So I now have full screen LD output, although a bit choppy.

Thanks to everyone for your help.


Moderated by  R. Belmont 

Who's Online Now
4 registered members (robcfg, Darkstar, Cpt. Pugwash, EoceneMiacid), 150 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,664
Posts113,575
Members4,848
Most Online324
Dec 20th, 2018
Powered by UBB.threads™ PHP Forum Software 7.6.1.1
(Release build 20180111)
Page Time: 0.033s Queries: 14 (0.016s) Memory: 5.6520 MB (Peak: 5.8647 MB) Zlib enabled. Server Time: 2019-07-15 18:38:17 UTC