Previous Thread
Next Thread
Print Thread
Page 84 of 536 1 2 82 83 84 85 86 535 536
Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
Originally Posted By judge
to update your source tree to revision 6143 do:
Code:
svn update -r6143


Thank you, i tried without success.


Joined: Jan 2006
Posts: 3,690
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,690
I think you must be in you mess folder and launch svn from there (either adding H:\svn\bin to PATH, or launching H:\svn\bin\svn.exe update -r6143 )

but it's been quite some time since I last used svn in windows (without tortoisesvn), hence I could be wrong

Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
Originally Posted By etabeta78
I think you must be in you mess folder and launch svn from there (either adding H:\svn\bin to PATH, or launching H:\svn\bin\svn.exe update -r6143 )

but it's been quite some time since I last used svn in windows (without tortoisesvn), hence I could be wrong


This info was very helpful and it works. smile

Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
Originally Posted By Just Desserts
Originally Posted By Anna Wu
SVN r6149
cdimono1 driver (in progress)

I think the sound was better with SVN r6143 in some games like Space Ranger.


Could you be more specific? I have listened to the audio in Space Ranger between r6143 and r6149, and did not notice any difference.


I think you are right. Here the comparison between SVN r6143 and SVN r6149 and the Space Ranger sound.

mess cdimono1 -r 640x480 -window -nonewui -nodebug -nolog -wavwrite sr.wav -bios 0 -cdrom "C:\Emulator\Mess\Software\CD-I\CDROM\Space Ranger.chd"

Last edited by Anna Wu; 10/20/09 08:42 PM.
Joined: Dec 2006
Posts: 531
M
Senior Member
Offline
Senior Member
M
Joined: Dec 2006
Posts: 531
Originally Posted By Curt Coder
Bondwell 12/14 floppy loading is broken once again frown

Fixed by removing nec765_idle() from the seek setup function. It was making it think that the recalibrate had finished when it hadn't, thus making the FDC treat Sense Drive Status as an invalid command. I tested the PCW driver after the change and it seems to still be working, post a reply if it breaks something else.


- Barry Rodewald
Joined: Feb 2008
Posts: 326
M
Senior Member
Offline
Senior Member
M
Joined: Feb 2008
Posts: 326
Only thing noticed not to work now is Elwro 800, that line was in Mariusz patch for Elwro. So here something is definitly not ok.

Joined: Dec 2006
Posts: 531
M
Senior Member
Offline
Senior Member
M
Joined: Dec 2006
Posts: 531
Well, the Bondwell checks the main status register, and if either bit 4 or 5 is set, then it waits and checks again, until neither bit is set. Bit 5 is execution mode, and should be set high during a seek/recalibrate operation. nec765_idle() clears both bits.


- Barry Rodewald
Joined: Dec 2006
Posts: 531
M
Senior Member
Offline
Senior Member
M
Joined: Dec 2006
Posts: 531
Ok, appears as though the FDC Busy flag is set, which it as I understand it, shouldn't be during a seek or recalibrate. Having the busy flag in the main status register reset at the beginning of a seek/recalibrate gets elwro800 running, and booting CP/J. Bondwell 12/14 still works, and I tested the PCW, CPC and X68000 drivers which also still appear to work. Reply if you know of any drivers broken by this change.


- Barry Rodewald
Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
SVN r6152

BW12/BW15 boot disks : working
(Still can not use the keyboard input but this is another problem)

Elwro boot disks (CP/J, Amstrad) boot disks : working

PCW8256 boot disks : working

Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
Originally Posted By Anna Wu
SVN r6152

BW12/BW15 boot disks : working
(Still can not use the keyboard input but this is another problem)

Elwro boot disks (CP/J, Amstrad) boot disks : working

PCW8256 boot disks : working


EDIT: Found the reason, I was not waiting long enough. smile

Page 84 of 536 1 2 82 83 84 85 86 535 536

Link Copied to Clipboard
Who's Online Now
2 members (MrBogi, 1 invisible), 36 guests, and 4 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,975
Posts117,909
Members5,003
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com