Previous Thread
Next Thread
Print Thread
Page 4 of 5 1 2 3 4 5
Joined: Aug 2005
Posts: 265
M
Senior Member
Offline
Senior Member
M
Joined: Aug 2005
Posts: 265
Originally Posted By Carbon
You need a version of Xcode < 3 apparently.

frown And I was about to grab the source and try and get up to date a bit too!

Ironically I only updated XCode last night. Although it was already on v3 anyway, just not the latest.

[EDIT]PS: Cheers Dave & Zuki. Nice to see the project not die entirely. I just hope you don't get bombarded with too many 'X game don't work' questions grin

Last edited by Martin; 01/10/10 01:04 PM.
Joined: Jan 2010
Posts: 2
T
Member
Offline
Member
T
Joined: Jan 2010
Posts: 2
Hi,
Iīm new to this place here, and I was and still am a little confused as to why my neo-geo roms suddently stopped working! smirk

I audited the games and I clicked on "Get Info", it tells me that the Audit Status is Bad! In every Rom I looked so far, it tells me that something is missing in the BIOS. So, I guess the reason why they arenīt working seems to be that the Bios is outdated ... even when I find a 0.135 Bios, where do I put it? There is no Folder for that ... . Sorry, if my english might be a lil broken! smirk
Is there even a exact Bios for 0.135 or can I use a version that is a lil older like 0.131 or so aswell? The Documentation sadly doesnīt tell me anything about where to put a newer Bios, I already checked! smirk
Since some here are actually working on the project, Iīm sure you know better than me where something has to go! smirk

Joined: Jan 2006
Posts: 3,690
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,690
the bios must be in the roms/ directory, zipped

Joined: Jan 2010
Posts: 2
T
Member
Offline
Member
T
Joined: Jan 2010
Posts: 2
Thank you soooo much! laugh I used a Bios for Mame version 0.131 and it worked instantly! laugh All my Neo Geo Games I tested worked flawless! laugh
That made my day! ^^

Joined: Jan 2010
Posts: 2
S
Member
Offline
Member
S
Joined: Jan 2010
Posts: 2
Quick question: for games that require a CHD, do you still put them in a subdirectory in the ROMS dir, or just put them in the Hard Disk Images directory?

Joined: Jan 2010
Posts: 2
S
Member
Offline
Member
S
Joined: Jan 2010
Posts: 2
I figured out the CHD thing, has there been a fix for the slowness issue for games like KI?

Joined: Jan 2010
Posts: 1
C
Member
Offline
Member
C
Joined: Jan 2010
Posts: 1
My keyboard isn't working within games. I can't even enter OK to get past the initial Legal warning. I'm on a Mac mini (intel) running 10.6.2 and MAME OS X 0.135. I have the older Apple bluetooth keyboard. Is there an incompatibility with the bluetooth keyboard or is there some setting I need to change?

Joined: May 2010
Posts: 1
W
Member
Offline
Member
W
Joined: May 2010
Posts: 1

ok... ive been at this for days, scouring the net, googling everything
trying out everything i have read about....
Im using MAME OSX 0.135 on an iBOOK G4 OSX 10.4.11(power pc g4 1.1)
struggling to get Streetfighter 3 to work to little avail....
initially "missing files blah blah"
so i hunted and found
33s000.chd
cap-33s-2.chd
sf3000.chd
sf33usa.bin

tried again, no go.... then i downloaded all the versions of sf3 i could find
put the missing files in each of them, actually-each sf3 zip has all the diff version files in each.... and rezipped into the roms folder... (someone did this and it worked)
i put the chd files into the hard disk images file also, unzipped...
then i redirected mame to my roms folder..... as i saw someone do that
tried each of them again...no go

i saw something on youtube, the guy put the bin file zipped and japan no cd file zipped in the roms folder, as well as a reg folder with all the sf3 files unzipped
into the roms folder as well...
i also have the neogeo bios(though it might be an older one)
i found the hyper neogeo 64 bios, and uni-bios-23
maybe i need the japan no cd bios- not sure if thats the one included in the rom?
after all this i audited my roms, and nothing came up

i can now get streetfighter 3 to start,
"there are known problems with this game"
and initially with a "missing/incorrect rom" statement
tho i just tried again, and that didnt come up. but the known probs statement does, in a yellow window.....

the game runs, but its stuttering badly, running less than half speed
im guessing its a frames per second issue....
and another USA version opens at a Cps3 screen, and asks me if i want to rewrite the game, will take 70 mins...i dont know what that means so i havent tried...

i have also come across the mention of the need for NVRAM files, but i havent found much more info pertaining to that

i dont know if my problems are older ROM copies (ive tried to use newer releases)
i also noticed some of the files (10,20,30,31,40,41,50,51,60,61), in some ROM folders were 'document files', i made sure to have all 'unix executable files' instead, have no idea if that makes a diff?
or if its something that has been renamed by MAME in an update of ROM names?,
or if my computer not being Intel is an issue? it is a few years old...sigh*

also trying to play samurai showdown on MAME OSX- files missing log...
and the neo geo bios is recognized, but it says looking for: (this), but found: (that)
so i dont know how to fix that either.... as samurai showdown 2,3,and 4 work fine on MACMAME with the neogeo bios i have, but not on MAME OSX, although samurai showdown 5 is another issue, it doesnt show up on MACMAME, or MAME OSX.... but i havent fussed with those as much as streetfighter, so i dont know...
i still have to find all the missing files, and rezip all concerned again..yadda yadda.

at this point im considering trying out SDLMAME, or even a windows emulator, and run a windows MAME on that...!!! i wont give up though,
im still hoping to play Streetfighter 3 online, but i read u cant do that on MAME OSX, but on Windows MAME instead, with something called Kaillera... digging around through all this shows me i have ALOT to learn.

sorry for the long post, but i would really appreciate some help
Ive tried to be as thorough as possible, hope its nothing stupid i missed
thanks for reading through all this...take care!!

Joined: Feb 2007
Posts: 549
S
Senior Member
Offline
Senior Member
S
Joined: Feb 2007
Posts: 549
Take a deep breath and read the MAME FAQ, especially the bits about ROMs. There's a link to it earlier in the thread.

Joined: Oct 2005
Posts: 351
R
Senior Member
Offline
Senior Member
R
Joined: Oct 2005
Posts: 351
@wraithenwind

If the game is stuttering a lot it just means your computer is not powerful enough to run it at full speed. That's all there is to it. I also have the "game issues/not 100%" screen and yet I can run it at full speed (and even at 5 times the full speed by hitting F10).

Trying to run it on Windows Mame through a windows emulator will probably result only in even worse performance. Do I have to explain why?

About the "rewrite the game" message. There are basically two versions of this game, "with CD" and "without CD", the versions with CD require a chd (image of the CD) to run them in MAME and they will require to rewrite the game at FIRST BOOT ONLY. It takes a lot of time (as much as it takes in reality) but once it is done MAME creates a quite large NVRAM file which is basically a save, and once you have that NVRAM file you can run the game without rewriting the game anymore at boot time. The versions "with CD" and "without CD" don't have a noticeable difference in performance during gameplay.

Hope this helps.

BTW you're not supposed to infringe copyright laws, so if you do it, at least don't say it.

Page 4 of 5 1 2 3 4 5

Moderated by  Dave Dribin 

Link Copied to Clipboard
Who's Online Now
0 members (), 19 guests, and 2 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,993
Posts118,153
Members5,005
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com