Previous Thread
Next Thread
Print Thread
Page 65 of 120 1 2 63 64 65 66 67 119 120
Joined: Aug 2009
Posts: 1,148
Likes: 12
Kale Offline OP
Very Senior Member
OP Offline
Very Senior Member
Joined: Aug 2009
Posts: 1,148
Likes: 12
iirc Bishoujo Janshi Suchie Pai serial crap was related to romset v1.00 and not v1.01, you've checked that, right?

Kale #59709 03/06/10 06:14 PM
Joined: Jan 2006
Posts: 3,690
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,690
yeah I tested that rom, and I think the problem is fixed: simply reverting your fix, Start was not recognized anymore. with the current code, it is.

or should I look for different issues?

Joined: Aug 2009
Posts: 1,148
Likes: 12
Kale Offline OP
Very Senior Member
OP Offline
Very Senior Member
Joined: Aug 2009
Posts: 1,148
Likes: 12
Think it was just the start button, can't really remember smile

Joined: Jan 2010
Posts: 92
X
Xor Offline
Member
Offline
Member
X
Joined: Jan 2010
Posts: 92
Whoa, weird. I tried them now and super family tennis, sugoi hebereke and super back to the future works. The only difference this time is that I explicitly started each game from the commandline while in the earlier tests I used the built-in file manager to select various games in succession. Tetris Battle Gaiden still turns black if you wait for the demonstration sequence (which shows gameplay) though (both in bobz version and in 0.136).

Also tried Dokapon Gaiden - Honoo no Audition which gives black screen (both bobz and 0.136)

I will make some more tests with a new build tomorrow.

Xor #59716 03/06/10 06:55 PM
Joined: Jan 2006
Posts: 3,690
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,690
thanks.

btw, for the time being avoid using the internal file manager, or at least hard-reset emulation with Shift+F3 after you loaded a game

SNES emulation is currently affected by a bunch of multisession bugs which will be fixed once the PPU will become a device (after 0.137)

Kale #59721 03/06/10 10:21 PM
Joined: Sep 2009
Posts: 15
J
Member
Offline
Member
J
Joined: Sep 2009
Posts: 15
The problem with offset-per-tile mode is that vshift isn't updated using the new ypos.

Joined: Mar 2001
Posts: 16,911
Likes: 56
R
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,911
Likes: 56
See, now that's the kind of bug report I can really get behind smile

Joined: Jan 2006
Posts: 3,690
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,690
@jbo_85: do you have a proposal for a fix? otherwise, I will take a look at vshift tomorrow (I'm currently busy with additional controller types)...

Kale #59724 03/06/10 10:53 PM
Joined: Sep 2009
Posts: 15
J
Member
Offline
Member
J
Joined: Sep 2009
Posts: 15
It can be fixed by putting:
yshift = ypos & ((8 << tilesize) - 1);
on line 728 in video/snes.c.

Joined: Jan 2006
Posts: 3,690
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,690
sir, you made my day laugh




Thanks a lot for spotting the problem and providing a solution.

Page 65 of 120 1 2 63 64 65 66 67 119 120

Link Copied to Clipboard
Who's Online Now
2 members (2 invisible), 19 guests, and 5 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics9,085
Posts119,081
Members5,014
Most Online890
Jan 17th, 2020
Our Sponsor
These forums are sponsored by Superior Solitaire, an ad-free card game collection for macOS and iOS. Download it today!

Superior Solitaire
Forum hosted by www.retrogamesformac.com