Previous Thread
Next Thread
Print Thread
Page 3 of 4 1 2 3 4
Re: I have noticed these regressions on 0.136 [Re: Barry Nelson] #59370 02/21/10 10:17 AM
Joined: Aug 2004
Posts: 1,394
Robbbert Offline
Very Senior Member
Offline
Very Senior Member
Joined: Aug 2004
Posts: 1,394
More regressions...


hp48sx doesn't start

amu880 has broken keyboard

max produces black screen

x68000 cannot read disks

Re: I have noticed these regressions on 0.136 [Re: Robbbert] #59372 02/21/10 11:21 AM
Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline
Very Senior Member
Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
Originally Posted By robbbert
More regressions...


hp48sx doesn't start

amu880 has broken keyboard

max produces black screen

x68000 cannot read disks


The max driver is working for me (SVN r7441)
Can load carts without problems.

The x68000 driver has problems to read disks.
Harddisk support is ok.

Last edited by Anna Wu; 02/21/10 11:23 AM.
Re: I have noticed these regressions on 0.136 [Re: Anna Wu] #59380 02/22/10 08:30 AM
Joined: Feb 2005
Posts: 449
C
Curt Coder Offline
Senior Member
Offline
Senior Member
C
Joined: Feb 2005
Posts: 449
amu880 keyboard was broken before the PIO changes, those other drivers don't use a Z80PIO at all.

Re: I have noticed these regressions on 0.136 [Re: Curt Coder] #59381 02/22/10 08:56 AM
Joined: Aug 2004
Posts: 1,394
Robbbert Offline
Very Senior Member
Offline
Very Senior Member
Joined: Aug 2004
Posts: 1,394
huh? i never said anything about the PIO in this thread. As far as I know, it is working fine.

Re: I have noticed these regressions on 0.136 [Re: Robbbert] #59383 02/22/10 09:58 AM
Joined: Feb 2005
Posts: 449
C
Curt Coder Offline
Senior Member
Offline
Senior Member
C
Joined: Feb 2005
Posts: 449
Nevermind, just a "i didn't do it" reflex smile The amu880 keyboard is not even read by the PIO, gotta fix it some day...

Re: I have noticed these regressions on 0.136 [Re: Curt Coder] #59384 02/22/10 10:12 AM
Joined: Aug 2004
Posts: 1,394
Robbbert Offline
Very Senior Member
Offline
Very Senior Member
Joined: Aug 2004
Posts: 1,394
A regression of a different kind... my dev box won't start up. Seems the flaky video card has finally breathed its last. Because of lack of time to shop around for a new one, i won't be doing any emulating for quite a while.

Re: I have noticed these regressions on 0.136 [Re: Robbbert] #59905 03/09/10 10:21 PM
Joined: Oct 2009
Posts: 8
P
PeteD Offline
Member
Offline
Member
P
Joined: Oct 2009
Posts: 8
Not sure if this is the place to ask but I can't get BBC disk images to work. *CAT just gives "Disk fault 18 at 00/FF". I'm unsure of when this stopped working because for some reason up until today I'd been using a debug build from Jan 2009 which the disk stuff worked fine on.

Tried with IMG and SSD image types.


Pete

Re: I have noticed these regressions on 0.136 [Re: PeteD] #59906 03/09/10 10:30 PM
Joined: May 1999
Posts: 157
JoJo Offline
Senior Member
Offline
Senior Member
Joined: May 1999
Posts: 157
Originally Posted By PeteD
Not sure if this is the place to ask but I can't get BBC disk images to work. *CAT just gives "Disk fault 18 at 00/FF". I'm unsure of when this stopped working because for some reason up until today I'd been using a debug build from Jan 2009 which the disk stuff worked fine on.



Out of curiosity, have tapes ever worked on BBC? I've tried to load a .uef tape (*TAPE, then CHAIN""), but didn't succeed.


JoJo
Re: I have noticed these regressions on 0.136 [Re: JoJo] #59908 03/09/10 11:17 PM
Joined: Oct 2009
Posts: 8
P
PeteD Offline
Member
Offline
Member
P
Joined: Oct 2009
Posts: 8
It would seem not. I tried with the older MESS I had (0.129) and it just searches forever.

It's a pain these don't work although I seem to be able to use a combinations of new and old versions to do what I want but there's no doubt been some fixes since the 0.129.

What I'm using MESS for atm (or at least trying to) is debugging bbc and electron stuff as I'm working on porting some beeb/electron games to the Atari 800 and the debuggers in the dedicated emulators are fairly lacking in functionality.

atm I've got 0.129 for debugging beeb stuff and 0.136 for Electron, which strangely enough has working tape emulation smile


Pete

Re: I have noticed these regressions on 0.136 [Re: PeteD] #59921 03/10/10 11:41 AM
Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline
Very Senior Member
Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
Originally Posted By PeteD
Not sure if this is the place to ask but I can't get BBC disk images to work. *CAT just gives "Disk fault 18 at 00/FF". I'm unsure of when this stopped working because for some reason up until today I'd been using a debug build from Jan 2009 which the disk stuff worked fine on.

Tried with IMG and SSD image types.


Pete


The last working version for the BBC Micro B ... driver and Floppy Disk support was the version 0.133

I never get working any Floppy Disk or Tape on the BBC Master driver in the past.

Last edited by Anna Wu; 03/10/10 11:42 AM.
Page 3 of 4 1 2 3 4

Who's Online Now
1 registered members (Carbon), 53 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,791
Posts115,714
Members4,908
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.3