Previous Thread
Next Thread
Print Thread
Page 140 of 536 1 2 138 139 140 141 142 535 536
Joined: Apr 2006
Posts: 729
Senior Member
Offline
Senior Member
Joined: Apr 2006
Posts: 729
Anytime I got the megadriv.c error recently, I found that running make without any -j flag allowed me to complete compile. Not sure why, though.




Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
Originally Posted By angrylion
What could it be?
SVN r7890, Windows, 32-bit, MinGW (GCC 4.4.3) downloaded from mamedev.org, clean compilation using either
make TARGET=mess
or
make TARGET=mess tools
I get this error:
Code:
Compiling src/mame/drivers/megadriv.c...
src/mame/drivers/megadriv.c: In function 'void driver_init_x32x(running_machine*
)':
src/mame/drivers/megadriv.c:6577: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
make: *** [obj/windows/mess/mame/drivers/megadriv.o] Error 1


SVN r7890 compile is working for me (GCC 4.4.3 32-bit, WinXP Pro SP3)
make TARGET=mess
make TARGET=mess tools

You really make a clean compile ?
Try to make all (src + obj)new.

Meanwhile, you can use bobz daily SVN build .

Last edited by Anna Wu; 04/24/10 01:37 PM.
Joined: Aug 2004
Posts: 1,444
Likes: 6
Very Senior Member
Offline
Very Senior Member
Joined: Aug 2004
Posts: 1,444
Likes: 6
I fixed this in r7884, by changing _32x to x32x, seems the compiler doesn't like the underscore.

Joined: Mar 2001
Posts: 16,757
Likes: 29
R
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,757
Likes: 29
Uhh, no. That error means your RAM is faulty and/or overheated. Changing random things about the code (e.g. the underscore) may make it succeed for a time, but it's not actually fixing the problem and it makes the code uglier. (This is why building without -j helps - the CPU is working less and the system is cooler).

Last edited by R. Belmont; 04/24/10 02:45 PM.
Joined: Aug 2009
Posts: 667
Senior Member
Offline
Senior Member
Joined: Aug 2009
Posts: 667
Hi I had the same problem. But it only started after moving to 0.137. 0.136 didn't had this problem.

Joined: Sep 2007
Posts: 40
A
Member
Offline
Member
A
Joined: Sep 2007
Posts: 40
On my Pentium 4 HT the problem, which persisted when building without -j, has been solved by adding -j2.

Joined: Dec 1999
Posts: 1,176
J
Very Senior Member
Offline
Very Senior Member
J
Joined: Dec 1999
Posts: 1,176
I'm not quick to rule out genuine bugs in GCC these days....

Joined: Mar 2001
Posts: 16,757
Likes: 29
R
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,757
Likes: 29
ICEs that only happen sometimes on some machines are hardware faults 9 times out of 10.

Joined: Dec 2006
Posts: 529
M
Senior Member
Offline
Senior Member
M
Joined: Dec 2006
Posts: 529
r7892
Fujitsu FM-Towns

Rainbow Islands Extra Version (locks up after first island)


Death Brade (music doesn't work, scrolling issues)


Viewpoint (offset graphics)


- Barry Rodewald
Joined: Mar 2001
Posts: 16,757
Likes: 29
R
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,757
Likes: 29
Very cool smile

Page 140 of 536 1 2 138 139 140 141 142 535 536

Link Copied to Clipboard
Who's Online Now
0 members (), 19 guests, and 2 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,943
Posts117,565
Members4,994
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com