Previous Thread
Next Thread
Print Thread
Page 143 of 528 1 2 141 142 143 144 145 527 528
Re: SVN builds - new driver flood [Re: Robbbert] #61361 04/28/10 10:03 PM
Joined: Mar 2006
Posts: 1,033
L
Lord Nightmare Offline
Very Senior Member
Offline
Very Senior Member
L
Joined: Mar 2006
Posts: 1,033
Re-encrypting them isn't terribly hard, the address and data swaps are static, and mame already has good handlers for dealing with those.
The REAL problem is every single pegasus software rom (and the bioses too?) has a serial number embedded in it which is compared against the serial number set on the machine using diodes (and sealed under some epoxyish white putty stuff); if the numbers don't match, the software doesn't run. The bios can apparently be patched to remove/bypass this check, but a better way would probably be to auto-patch (IN RAM! not permanently) every rom to have the correct serial number in it, so the bios checks pass.

LN


"When life gives you zombies... *CHA-CHIK!* ...you make zombie-ade!"
Re: SVN builds - new driver flood [Re: Lord Nightmare] #61368 04/29/10 01:02 AM
Joined: Aug 2004
Posts: 1,385
Robbbert Offline
Very Senior Member
Offline
Very Senior Member
Joined: Aug 2004
Posts: 1,385
Not quite true.. only some of the roms have the check. For example, Monitor 2.3 and 2.3a has no checking. I have a protection-defeat handler in the code which will allow anything to pass the test - no patching is used.

Last edited by robbbert; 04/29/10 01:03 AM.
Re: SVN builds - new driver flood [Re: Robbbert] #61370 04/29/10 07:05 AM
Joined: Feb 2005
Posts: 449
C
Curt Coder Offline
Senior Member
Offline
Senior Member
C
Joined: Feb 2005
Posts: 449
Just about any driver is now crashing on startup if you use the newui.

-----------------------------------------------------
Exception at EIP=7C9369AA (no map): ACCESS VIOLATION
While attempting to read memory at 00000000
-----------------------------------------------------
EAX=00000000 EBX=00000086 ECX=06F605D0 EDX=00000000
ESI=06F60188 EDI=06F60198 EBP=0022F724 ESP=0022F504

Re: SVN builds - new driver flood [Re: Curt Coder] #61375 04/29/10 12:14 PM
Joined: Aug 2004
Posts: 1,385
Robbbert Offline
Very Senior Member
Offline
Very Senior Member
Joined: Aug 2004
Posts: 1,385
Yes, that happens to me too. Investigating..

Re: SVN builds - new driver flood [Re: Robbbert] #61377 04/29/10 12:38 PM
Joined: Jan 2006
Posts: 3,687
etabeta78 Offline
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,687
it does not reproduce here with the latest svn (7930), I've just started c64 and ibmpc5160 with newui and no crash.

the problem you experienced might have been related to the crash I've just fixed in my last commit: MESS was failing software list validation if any xml was missing in the hash path.

Re: SVN builds - new driver flood [Re: etabeta78] #61378 04/29/10 01:03 PM
Joined: Feb 2005
Posts: 449
C
Curt Coder Offline
Senior Member
Offline
Senior Member
C
Joined: Feb 2005
Posts: 449
Yes, newui is working now, thank you smile

Re: SVN builds - new driver flood [Re: Curt Coder] #61379 04/29/10 01:13 PM
Joined: Aug 2004
Posts: 1,385
Robbbert Offline
Very Senior Member
Offline
Very Senior Member
Joined: Aug 2004
Posts: 1,385
I tested one step at a time and found that r7914 caused the problem for me. I have reverted it.

Re: SVN builds - new driver flood [Re: Robbbert] #61381 04/29/10 01:37 PM
Joined: Jan 2006
Posts: 3,687
etabeta78 Offline
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,687
fwiw, 7914 gave no problem here (win xp 32bit)

Re: SVN builds - new driver flood [Re: etabeta78] #61382 04/29/10 01:44 PM
Joined: Aug 2004
Posts: 1,385
Robbbert Offline
Very Senior Member
Offline
Very Senior Member
Joined: Aug 2004
Posts: 1,385
That is what I use, but it was very unstable, sometimes would work, the next time instant crash. Seemed like memory issues all over again with the random behavior. I tested with Super80, but I'd expect trouble with any system that had the choice of Mount, Create, Unmount in the device menu.

Last edited by robbbert; 04/29/10 01:45 PM.
Re: SVN builds - new driver flood [Re: Robbbert] #61387 04/29/10 06:48 PM
Joined: Mar 2006
Posts: 1,033
L
Lord Nightmare Offline
Very Senior Member
Offline
Very Senior Member
L
Joined: Mar 2006
Posts: 1,033
The patch in question was a partial (apparently incomplete? It's hard to tell) fix for the mess of osd_free vs global_free vs mame_free vs free functions used in newui and wimgtool. I think Firewave can't actually truly fix it without messing with some SDL OSD code which R. Belmont has a lock on, due to some problems with dependencies.
R. Belmont: maybe talk to firewave and see if you can figure out what exactly needs fixing? It sounded bad on IRC.

LN


"When life gives you zombies... *CHA-CHIK!* ...you make zombie-ade!"
Page 143 of 528 1 2 141 142 143 144 145 527 528

Who's Online Now
1 registered members (belegdol), 49 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,693
Posts114,287
Members4,865
Most Online510
Aug 26th, 2019
Powered by UBB.threads™ PHP Forum Software 7.7.3