Previous Thread
Next Thread
Print Thread
Page 2 of 9 1 2 3 4 5 6 7 8 9
Re: M1 Android [Re: neko68k] #70234
05/31/11 11:04 PM
05/31/11 11:04 PM
Joined: Apr 2011
Posts: 32
N
neko68k Offline OP
Member
neko68k  Offline OP
Member
N
Joined: Apr 2011
Posts: 32
zedblade is working for me. zerowing is not because it looks like its looking for the wrong roms(genesis not arcade, my bad :), I'll fix that in the next update. can you post a logcat for zedblade?

Re: M1 Android [Re: neko68k] #70642
06/11/11 04:21 AM
06/11/11 04:21 AM
Joined: Mar 2001
Posts: 15,988
USA
R
R. Belmont Offline
Very Senior Member
R. Belmont  Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 15,988
USA
I've finally gotten to set up my sdcard properly and try this out and I'm having a similar problem - no matter what game I pick, the app puts a play icon in the notify bar and then force quits. I've tried, among others, Marble Madness, Haunted Castle, Daytona, Journey, Tron, and a couple of Genesis games.

This is on an HTC EVO 4G running Gingerbread 2.3.3 (HTC/Sprint's official OTA update, no CM or rooting or anything).

Re: M1 Android [Re: neko68k] #70670
06/12/11 04:04 PM
06/12/11 04:04 PM
Joined: Apr 2011
Posts: 32
N
neko68k Offline OP
Member
neko68k  Offline OP
Member
N
Joined: Apr 2011
Posts: 32
I just pushed an update that should have rom loading acting a lot better. This fixes the above zerowing issue and adds basic error handling to rom loading including a toast to tell you why it failed instead of crashing horribly smile

Edit:
oh and I'm working on the options screen. at least then I can get it so it doesn't require stuff to live in /sdcard/m1 since this is an issue for some people.

Last edited by neko68k; 06/12/11 04:05 PM.
Re: M1 Android [Re: neko68k] #70842
06/16/11 07:18 PM
06/16/11 07:18 PM
Joined: Aug 2008
Posts: 14
New York, NY, USA
N
N e o L o g i X Offline
Member
N e o L o g i X  Offline
Member
N
Joined: Aug 2008
Posts: 14
New York, NY, USA
hi again! sorry i didn't provide a logcat before; i updated to the current version on the market (i think it says 1.24).

anyways, new problem: the rom list doesn't want to load up. i have the m1.xml from early june and the lists from may. below is a logcat filtered to only show m1:

Code:
D/dalvikvm( 6584): Trying to load lib /data/data/com.neko68k.emu.M1Android/lib/libM1.so 0x405147f0
D/dalvikvm( 6584): Added shared lib /data/data/com.neko68k.emu.M1Android/lib/libM1.so 0x405147f0
I/ActivityManager( 1207): Displayed com.neko68k.emu.M1Android/com.neko68k.M1.M1Android: +2s80ms
I/ActivityManager( 1207): Displayed com.neko68k.emu.M1Android/com.neko68k.M1.GameListActivity: +640ms
I/ActivityManager( 1207): Displayed com.neko68k.emu.M1Android/com.neko68k.M1.GameListActivity: +1s540ms


maybe there's something up w/GameListActivity?

Re: M1 Android [Re: neko68k] #70854
06/17/11 04:31 AM
06/17/11 04:31 AM
Joined: Apr 2011
Posts: 32
N
neko68k Offline OP
Member
neko68k  Offline OP
Member
N
Joined: Apr 2011
Posts: 32
No prob. 1.23 had the romlist issue. 1.24 should have that fixed. I know I'm running it and at least one other person that isn't having that problem anymore. I forgot I had the rompath hard coded so I fixed that but I didn't notice that m1 appends a ; to the end of it when it reads the ini so 1.23 had that issue because it wasn't finding the roms at all. I fixed that and pushed 1.24 this morning to fix it. Though it was mentioned to me that the romlist may not update properly if the service never dies(which it doesn't sometimes, I dunno why) You might want to try force quitting or going in to menu|settings|applications and kill it from there.

It should be ok as long as your ini points at your rom folder. If you dont have an ini it doesn't init at all anymore, keeps stuff from getting weird. FYI you can also filter for "I/M1Android" since I spew a few debugging messages.

This android shit is a pain smile If you're ever looking over the source, try not to laugh because its such a horrible hack laugh

Re: M1 Android [Re: neko68k] #70878
06/17/11 12:59 PM
06/17/11 12:59 PM
Joined: Mar 2001
Posts: 15,988
USA
R
R. Belmont Offline
Very Senior Member
R. Belmont  Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 15,988
USA
1.23 couldn't find any roms for me so I'll try 1.24. Thanks for keeping up on this smile

Re: M1 Android [Re: neko68k] #70996
06/20/11 07:34 PM
06/20/11 07:34 PM
Joined: Aug 2008
Posts: 14
New York, NY, USA
N
N e o L o g i X Offline
Member
N e o L o g i X  Offline
Member
N
Joined: Aug 2008
Posts: 14
New York, NY, USA
no worries; i myself SUCK at java :P

FYI, i was on 1.24 when i took the above logcat. right now i looked at my ini file and saw that i apparently changed the rompath from /sdcard/m1/roms to simply roms expecting it to be read as a relative path, but after changing it back m1 now takes forever to action, and STILL NO ROMS show up in the list.

and now as i type my moto droid running cyanogenmod7 just went into soft-reboot. fantastic.

is running on my moto droid OCed to 800mhz simply a non-starter?

in the meantime, deadbeef player on android is satisfying my zerowing craving via genesis vgm laugh

Re: M1 Android [Re: neko68k] #73384
09/23/11 06:16 AM
09/23/11 06:16 AM
Joined: Jun 2001
Posts: 161
J
Jonathan Wilson Offline
Senior Member
Jonathan Wilson  Offline
Senior Member
J
Joined: Jun 2001
Posts: 161
I wonder how well a port to the Nokia N900 with a Ti OMAP 3430 @ 600MHz and running Nokia MAEMO Linux (with X and everything) would run...

Re: M1 Android [Re: neko68k] #73422
09/23/11 12:20 PM
09/23/11 12:20 PM
Joined: Mar 2001
Posts: 15,988
USA
R
R. Belmont Offline
Very Senior Member
R. Belmont  Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 15,988
USA
N900 isn't a port, it's just Linux. Since those are the same-ish specs as a BeagleBoard, get one and let us know...

Re: M1 Android [Re: neko68k] #73763
10/18/11 01:44 PM
10/18/11 01:44 PM
Joined: Feb 2003
Posts: 168
Mexico
mangamuscle Offline
Senior Member
mangamuscle  Offline
Senior Member
Joined: Feb 2003
Posts: 168
Mexico
I was thinking about buying a Hero H2000 (froyo 2.2, 416 mhz) and I wonder if there are any chances of M1 getting DRC for the 68000? I know atm mame has no backend for ARM, but since even Windows 8 will support said architecture, I suppose it is being considered (albeit I know this might be filed under "when helll freezes over" :S ).

Page 2 of 9 1 2 3 4 5 6 7 8 9

Moderated by  R. Belmont 

Who's Online Now
2 registered members (Tafoid, Vas Crabb), 56 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,566
Posts111,891
Members4,805
Most Online225
May 26th, 2014
Powered by UBB.threads™ PHP Forum Software 7.6.1.1
(Release build 20180111)
Page Time: 0.280s Queries: 14 (0.243s) Memory: 5.7321 MB (Peak: 5.9548 MB) Zlib enabled. Server Time: 2018-08-19 09:37:49 UTC