Previous Thread
Next Thread
Print Thread
Page 38 of 78 1 2 36 37 38 39 40 77 78
Re: The Sega Satan WIP/screenshot thread [Re: Kale] #72029 08/07/11 05:50 PM
Joined: Aug 2009
Posts: 1,140
Kale Offline OP
Very Senior Member
OP Offline
Very Senior Member
Joined: Aug 2009
Posts: 1,140
Improved CD timings, moved around some variables and removed various hacks.

It still crashes/puke on DMA-based FMVs (i.e. Command & Conquer, Clockwork Knight), but there's certainly a big improvement in both compatibility and FMV speed & playback now ^^:








Re: The Sega Satan WIP/screenshot thread [Re: Kale] #72053 08/07/11 09:20 PM
Joined: May 2011
Posts: 44
Y
yugffuts Offline
Member
Offline
Member
Y
Joined: May 2011
Posts: 44
Working with SVN build 12520, starting with my USA games first...

First, the bad news:

Dark Savior, Nights, Virtua On, Panzer Dragoon Zwei all used to show some graphics (or more), but now they immediately revert to the Saturn Console.

Other people are reporting success with World Series 98, but mine freezes right after the first little loading disc shows up. This used to allow me into the menus.

And now, the good news.

Daytona USA is working. I think that was already mentioned, so I'll forego the pictures.

Ultimate Mortal Kombat 3 is now playable, although graphics issues arise after you are uppercut into a new level (see pics 3 & 4).









Re: The Sega Satan WIP/screenshot thread [Re: yugffuts] #72054 08/07/11 10:00 PM
Joined: May 2011
Posts: 44
Y
yugffuts Offline
Member
Offline
Member
Y
Joined: May 2011
Posts: 44
And for my Japanese games. Same story, working with SVN build 12520.

First, the bad news:

Marvel Superheroes crashes at the intro FMV with the crashing blue blocks/lines. This was playable previously.


Good news:

Street Fighter: The Movie is playable again.

All Japan Pro Wrestling is playable now...I hit start at that loading screen to make it continue.







Bomberman is also working.




Re: The Sega Satan WIP/screenshot thread [Re: Kale] #72064 08/08/11 08:00 AM
Joined: Aug 2009
Posts: 667
Kaylee Offline
Senior Member
Offline
Senior Member
Joined: Aug 2009
Posts: 667
A few more seems to work:

Battle Monsters (USA) (but gameplay seems a bit fast)



Syukudai ga Tant-R (JAP): now goes ingame:


Guardian Force (JAP)


&

Space Invaders (JAP)


Last edited by Kaylee; 08/08/11 08:01 AM. Reason: spelling bee errors
Re: The Sega Satan WIP/screenshot thread [Re: Kale] #72065 08/08/11 08:29 AM
Joined: Aug 2009
Posts: 667
Kaylee Offline
Senior Member
Offline
Senior Member
Joined: Aug 2009
Posts: 667
Rayman (usa) gets to the start screen, but can't go further because no controls


it also complains about a vdp1: sprite list errors

Re: The Sega Satan WIP/screenshot thread [Re: Kale] #72068 08/08/11 12:59 PM
Joined: Aug 2009
Posts: 1,140
Kale Offline OP
Very Senior Member
OP Offline
Very Senior Member
Joined: Aug 2009
Posts: 1,140
Regression was with cd speed, going to test your reported issues but it should be ok now:


Re: The Sega Satan WIP/screenshot thread [Re: Kale] #72069 08/08/11 02:34 PM
Joined: Sep 2009
Posts: 239
D
Dr. Spankenstein Offline
Senior Member
Offline
Senior Member
D
Joined: Sep 2009
Posts: 239
Regression:

Saturn Bomberman Fight!! [J]

No longer accepts controller input during the opening FMV, so it can't be skipped.

Sounds effects playing during FMV are more out of sync than they were previously, they also repeat/stutter more often than before.

Re: The Sega Satan WIP/screenshot thread [Re: Kale] #72071 08/08/11 03:20 PM
Joined: Aug 2009
Posts: 667
Kaylee Offline
Senior Member
Offline
Senior Member
Joined: Aug 2009
Posts: 667
Regressions:

VR Soccer (USA) is now horribly slow, poor commentator has a nasty case of stuttering.


Re: The Sega Satan WIP/screenshot thread [Re: Kale] #72072 08/08/11 04:02 PM
Joined: Sep 2009
Posts: 239
D
Dr. Spankenstein Offline
Senior Member
Offline
Senior Member
D
Joined: Sep 2009
Posts: 239
r12529 makes the stuttering better and I can skip the FMV again smile

Re: The Sega Satan WIP/screenshot thread [Re: Kale] #72074 08/08/11 05:35 PM
Joined: Aug 2009
Posts: 1,140
Kale Offline OP
Very Senior Member
OP Offline
Very Senior Member
Joined: Aug 2009
Posts: 1,140
With latest Wachenröder started booting consistantly (uses 0x63 -> 0x06 command combo, so expect unbearable sound noise):













0x63 is get then delete sector data ... I bet that timing where it deletes the data isn't quite right.
And, obviously the two empty dialog boxes are yet another video bug (line window?)

Page 38 of 78 1 2 36 37 38 39 40 77 78

Who's Online Now
1 registered members (Carbon), 278 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,734
Posts114,829
Members4,879
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.3