Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
Only bottom 1/3 of picture being rendered? #72906 09/02/11 03:40 PM
Joined: Nov 2006
Posts: 52
N
Numbski Offline OP
Member
OP Offline
Member
N
Joined: Nov 2006
Posts: 52
So I am trying to set up a quick-and-dirty MAME box here at the office for people to play on using my Hot Rod joystick. Nothing is ever simple, is it? :\

At first, I tried using sdlmame's defaults, and it appeared that the picture was shifted up to the top 1/3 of the screen for all games. I then forced the screen resolution to the laptop's native screen resolution. When I did that, the picture shifted down, but only the bottom 1/3 of the game screen is getting rendered. I've tried playing with all sorts of settings with no luck. Any of this look familiar to you guys?








Re: Only bottom 1/3 of picture being rendered? [Re: Numbski] #72907 09/02/11 03:41 PM
Joined: Nov 2006
Posts: 52
N
Numbski Offline OP
Member
OP Offline
Member
N
Joined: Nov 2006
Posts: 52
While I'm at it, mame used to have a -hotrod switch. I don't suppose there's an equivalent to that now? The hotrod is wired with MAME's "old" (now *really* old) coin/start switch config...

Re: Only bottom 1/3 of picture being rendered? [Re: Numbski] #72908 09/02/11 03:46 PM
Joined: Mar 2001
Posts: 16,539
R
R. Belmont Online Content
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,539
That's bizarre. Have you tried both -video soft and -video opengl?

Re: Only bottom 1/3 of picture being rendered? [Re: Numbski] #72909 09/02/11 03:49 PM
Joined: Nov 2006
Posts: 52
N
Numbski Offline OP
Member
OP Offline
Member
N
Joined: Nov 2006
Posts: 52
I'll try soft. It's set to opengl now.

Re: Only bottom 1/3 of picture being rendered? [Re: Numbski] #72910 09/02/11 03:51 PM
Joined: Nov 2006
Posts: 52
N
Numbski Offline OP
Member
OP Offline
Member
N
Joined: Nov 2006
Posts: 52
Same result, with slightly clearer video (now *that* has me puzzled).

Re: Only bottom 1/3 of picture being rendered? [Re: Numbski] #72911 09/02/11 03:53 PM
Joined: Nov 2006
Posts: 52
N
Numbski Offline OP
Member
OP Offline
Member
N
Joined: Nov 2006
Posts: 52
The 1/3 and shifted picture was everything set to auto. This is with screen auto, aspect auto, and resolution set 1600x900.

Re: Only bottom 1/3 of picture being rendered? [Re: Numbski] #72912 09/02/11 03:54 PM
Joined: Mar 2001
Posts: 16,539
R
R. Belmont Online Content
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,539
Wow. The clearer video would be since opengl defaults to doing bilinear filtering, but missing 2/3rds of the screen in soft mode is a new one on me. I assume it's bad/immature drivers of some sort.

Windowed mode works fine, I assume? You could always maximize the window - it's not quite the same as full screen, but it should work.

Re: Only bottom 1/3 of picture being rendered? [Re: Numbski] #72913 09/02/11 04:00 PM
Joined: Nov 2006
Posts: 52
N
Numbski Offline OP
Member
OP Offline
Member
N
Joined: Nov 2006
Posts: 52
Yes, windowed mode works exactly as expected.

Re: Only bottom 1/3 of picture being rendered? [Re: Numbski] #73025 09/06/11 01:50 PM
Joined: Nov 2006
Posts: 52
N
Numbski Offline OP
Member
OP Offline
Member
N
Joined: Nov 2006
Posts: 52
Just a quick update on this - if I set up video-out I got similar results, however the picture was again shifted. I think I've figured it out. The laptop's driver can drive dual displays - internal and external. SDL is trying to center the picture in relationship to monitor 2, even when it's not hooked up, and even though I don't have sdlmame configured to span.

For our purposes, I got it fixed. Going to go start a second thread for the HotRod though. That one's bizarre...

Re: Only bottom 1/3 of picture being rendered? [Re: Numbski] #73026 09/06/11 01:55 PM
Joined: Mar 2001
Posts: 16,539
R
R. Belmont Online Content
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,539
MAME no longer supports the hotrod directly - PS/2 ports are a very dying breed, and it's assumed you can operate the key remapping UI if you insist on using one smile

Page 1 of 2 1 2

Moderated by  R. Belmont 

Who's Online Now
1 registered members (Carbon), 53 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,791
Posts115,714
Members4,908
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.3