Previous Thread
Next Thread
Print Thread
Page 7 of 9 1 2 3 4 5 6 7 8 9
Re: T/A Alphatronic PC? [Re: Spirantho] #110347
07/18/17 02:02 AM
07/18/17 02:02 AM
Joined: Jan 2012
Posts: 899
Bavaria
rfka01 Offline
Senior Member
rfka01  Offline
Senior Member
Joined: Jan 2012
Posts: 899
Bavaria
Quote
so now I get [:fdc] command read data mfm cmd=46 sel=0 chrn=(0, 0, 1, 256) eot=10 gpl=36 dtl=ff rate=5000
R. Belmont: and nothing else happens, apparently. hangs forever waiting on bit 6 of port 0xF9


Hmmm ... you probably thought of all that yourself ...

... did you try both ROM sets from my machines as they were physically dumped as opposed to read out by BASIC
... the disk manual states the boot priority:

a. If a module is inserted, it's loaded when the PC is switched on or reset.
b. If there is no module, but a ready disk station, the disk is loaded. If there is no disk inserted, the system waits for the correct insertion of a disk.
c. If neither a. nor b. are true, the system loads the internal BASIC interpreter.

... Bit 0 of IN 10H tells you if a Floppy unit is available (=1) or not ...


NCR DMV- DEC Rainbow- Siemens PCD- ITT 3030-Oly People- Acorn A5000- Olivetti M20
Re: T/A Alphatronic PC? [Re: Spirantho] #110348
07/18/17 02:50 AM
07/18/17 02:50 AM
Joined: Mar 2001
Posts: 15,965
USA
R
R. Belmont Online content
Very Senior Member
R. Belmont  Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 15,965
USA
Yeah, if I clear the floppy unit bit it boots right into ROM BASIC, except correctly now b/c the IPL is being used smile

Re: T/A Alphatronic PC? [Re: Spirantho] #110353
07/19/17 01:05 AM
07/19/17 01:05 AM
Joined: Jan 2012
Posts: 782
C
crazyc Offline
Senior Member
crazyc  Offline
Senior Member
C
Joined: Jan 2012
Posts: 782
[Linked Image]

Re: T/A Alphatronic PC? [Re: Spirantho] #110354
07/19/17 02:11 AM
07/19/17 02:11 AM
Joined: Mar 2001
Posts: 15,965
USA
R
R. Belmont Online content
Very Senior Member
R. Belmont  Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 15,965
USA
Disk BASIC doesn't quite boot as-is, but patching one byte in the boot sector clears the issue. Need to figure out what's actually going on there.

[Linked Image]

Re: T/A Alphatronic PC? [Re: Spirantho] #110355
07/19/17 06:09 AM
07/19/17 06:09 AM
Joined: Jan 2012
Posts: 899
Bavaria
rfka01 Offline
Senior Member
rfka01  Offline
Senior Member
Joined: Jan 2012
Posts: 899
Bavaria
WOW, congrats, to both of you! Will be testing later smile


NCR DMV- DEC Rainbow- Siemens PCD- ITT 3030-Oly People- Acorn A5000- Olivetti M20
Re: T/A Alphatronic PC? [Re: Spirantho] #110371
07/20/17 08:35 PM
07/20/17 08:35 PM
Joined: Jan 2012
Posts: 899
Bavaria
rfka01 Offline
Senior Member
rfka01  Offline
Senior Member
Joined: Jan 2012
Posts: 899
Bavaria
Both Disk BASIC and CP/M are working fine ... from drive A: smile

Mounting a known good disk image in B: gives you an error message from the Alphatronic:

[Linked Image]

Another thing I'd suggest is to set the number of disk drives to two - the F2 extension drive has no provision for a passthrough to a third or fourth drive.
If you search for pictures of the system, it's almost always a stack of the F1 and F2 drives.


NCR DMV- DEC Rainbow- Siemens PCD- ITT 3030-Oly People- Acorn A5000- Olivetti M20
Re: T/A Alphatronic PC? [Re: Spirantho] #110373
07/21/17 01:04 AM
07/21/17 01:04 AM
Joined: Mar 2001
Posts: 15,965
USA
R
R. Belmont Online content
Very Senior Member
R. Belmont  Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 15,965
USA
I've reduced the system to 2 drives and corrected the errors accessing the B: drive.

Re: T/A Alphatronic PC? [Re: Spirantho] #110377
07/21/17 02:21 AM
07/21/17 02:21 AM
Joined: Mar 2001
Posts: 15,965
USA
R
R. Belmont Online content
Very Senior Member
R. Belmont  Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 15,965
USA
And now... the ROM cartridge.

[Linked Image]
[Linked Image]
[Linked Image]
[Linked Image]

Re: T/A Alphatronic PC? [Re: Spirantho] #110379
07/21/17 03:06 AM
07/21/17 03:06 AM
Joined: Feb 2004
Posts: 1,968
Sydney, Australia
Vas Crabb Online content
Very Senior Member
Vas Crabb  Online Content
Very Senior Member
Joined: Feb 2004
Posts: 1,968
Sydney, Australia
German software with English chargen?

Re: T/A Alphatronic PC? [Re: Spirantho] #110380
07/21/17 06:48 AM
07/21/17 06:48 AM
Joined: Jan 2012
Posts: 899
Bavaria
rfka01 Offline
Senior Member
rfka01  Offline
Senior Member
Joined: Jan 2012
Posts: 899
Bavaria
There's a row of dip switches on the Mainboard

1-3 control the country setting: on/on/on: international keyboard, off/on/on: German keyboard
4 off: V24, on: Centronics
5 off: NTSC, on: PAL
6 no function

It's on p.179 (8-12) of the Royal alphatronics manual.

Edit: And they correspond to bits in the Port IN10 group:

[Linked Image]

Last edited by rfka01; 07/21/17 07:33 AM.

NCR DMV- DEC Rainbow- Siemens PCD- ITT 3030-Oly People- Acorn A5000- Olivetti M20
Page 7 of 9 1 2 3 4 5 6 7 8 9

Who's Online Now
4 registered members (Dam0, Vas Crabb, Pernod, dxl), 50 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,554
Posts111,751
Members4,801
Most Online225
May 26th, 2014
Powered by UBB.threads™ PHP Forum Software 7.6.1.1
(Release build 20180111)
Page Time: 0.061s Queries: 14 (0.019s) Memory: 5.7320 MB (Peak: 5.9535 MB) Zlib enabled. Server Time: 2018-07-19 11:34:45 UTC