Previous Thread
Next Thread
Print Thread
Page 5 of 7 1 2 3 4 5 6 7
Re: Can't start IBM5150 the way I want to [Re: Tinu] #77178 02/10/12 03:25 PM
Joined: Feb 2012
Posts: 62
T
Tinu Offline OP
Member
OP Offline
Member
T
Joined: Feb 2012
Posts: 62
Next question...
Whenever I change the floppy image with the built-in file manager, the emulation crashes a few seconds later. The floppy gets loaded correctly (e.g. I can see its contents with a "dir" command"), but then the emulated screen gets dim, and nothing happens anymore. MESS itself does not crash, just the emulated IBM5150.

Is this a problem with the emulator, or am I using it wrongly (i.e. is there another way to exchange the virtual floppy while the emulation is running)?

I also tried the IBM5160 emulation, but there the floppy adapter doesn't seem to work, I always get the floppy error at boot (601). DIP switches are set correctly.

Thanks! Martin

Re: Can't start IBM5150 the way I want to [Re: Tinu] #77179 02/10/12 03:28 PM
Joined: Dec 1999
Posts: 1,173
J
Justin Offline
Very Senior Member
Offline
Very Senior Member
J
Joined: Dec 1999
Posts: 1,173
The screen dimming means you hit the 'p' key, which pauses the emulation. After switching disks you'll want to hit Scroll Lock again to get the keyboard back to Full Emulation mode, that way 'p' will be typed like you want and not trigger the pause functionality.

Re: Can't start IBM5150 the way I want to [Re: Justin] #77180 02/10/12 03:37 PM
Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline
Very Senior Member
Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
The driver status for these drivers is still preliminary.

Re: Can't start IBM5150 the way I want to [Re: Tinu] #77181 02/10/12 03:43 PM
Joined: Feb 2012
Posts: 62
T
Tinu Offline OP
Member
OP Offline
Member
T
Joined: Feb 2012
Posts: 62
Ah... I suspected there was a user error somewhere. Thanks!
@Anna: So it's a known problem that the floppy in the IBM5160 does not work?

Thanks! Martin

Re: Can't start IBM5150 the way I want to [Re: Tinu] #77182 02/10/12 03:48 PM
Joined: Mar 2001
Posts: 16,300
R
R. Belmont Online Content
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,300
In general, the 386+ PC clones have gotten a lot more love than the genuine IBM machines. I'm a little surprised that means the floppy doesn't work though, the controller should be the same.

Re: Can't start IBM5150 the way I want to [Re: R. Belmont] #77183 02/10/12 03:53 PM
Joined: Feb 2012
Posts: 62
T
Tinu Offline OP
Member
OP Offline
Member
T
Joined: Feb 2012
Posts: 62
Originally Posted By R. Belmont
I'm a little surprised that means the floppy doesn't work though, the controller should be the same.

The difference between the 5150 and the 5160 is almost negligible. The BIOS of the 5160 is newer, maybe it runs some of the floppy adapter tests slightly differently, and thus triggers the 601 error. I'll try with the 5160 using other BIOS versions, maybe there is a difference there.
Regards, Martin

Re: Can't start IBM5150 the way I want to [Re: Tinu] #77184 02/10/12 03:59 PM
Joined: Mar 2001
Posts: 16,300
R
R. Belmont Online Content
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,300
Might be useful to know what the 601 error is. Surely the IBM error codes are fairly well known? smile

Re: Can't start IBM5150 the way I want to [Re: Tinu] #77185 02/10/12 04:10 PM
Joined: Jan 2012
Posts: 804
C
crazyc Offline
Senior Member
Offline
Senior Member
C
Joined: Jan 2012
Posts: 804
The 5160 and 5170a don't like the reply from the FDC after reset. It's due to the odd way IBM connected the UPD765.

Re: Can't start IBM5150 the way I want to [Re: R. Belmont] #77186 02/10/12 04:10 PM
Joined: Feb 2012
Posts: 62
T
Tinu Offline OP
Member
OP Offline
Member
T
Joined: Feb 2012
Posts: 62
Originally Posted By R. Belmont
Might be useful to know what the 601 error is. Surely the IBM error codes are fairly well known? smile

Yes, 601 is a "General diskette or adapter failure".

I now get a MESS crash when I start Windows 1.03: "Unable to locate input port 'pc_mouse_x'" Does anyone know what this means?
I have a com adapter installed, I have COM1 active in the DIP switches, and I have setup Win 1.03 with a Microsoft BUS/Serial Mouse.

Re: Can't start IBM5150 the way I want to [Re: Tinu] #77187 02/10/12 04:16 PM
Joined: Feb 2012
Posts: 62
T
Tinu Offline OP
Member
OP Offline
Member
T
Joined: Feb 2012
Posts: 62
Originally Posted By Tinu
I'll try with the 5160 using other BIOS versions, maybe there is a difference there.

BIOS Rev 1 and 2 don't trigger the floppy error, 3 and 4 do.

There seems to be some rework between 2 and 3: The memory test at bootup runs much faster with revision 3.

Apparently there is some imperfection in the floppy emulation which BIOS Rev 3 is not happpy with.

Regards, Martin

Page 5 of 7 1 2 3 4 5 6 7

Who's Online Now
2 registered members (rfka01, RColtrane), 158 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,683
Posts114,012
Members4,863
Most Online510
Aug 26th, 2019
Powered by UBB.threads™ PHP Forum Software 7.7.3