Previous Thread
Next Thread
Print Thread
Page 14 of 42 1 2 12 13 14 15 16 41 42
Joined: Mar 2001
Posts: 16,911
Likes: 56
R
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,911
Likes: 56
Nope. UME itself is minimally supported on Windows, and not at all on non-Windows.

Joined: May 2012
Posts: 429
Likes: 1
R
Senior Member
Offline
Senior Member
R
Joined: May 2012
Posts: 429
Likes: 1
try to make mame and mess just after (without making clean) and you'll know if you must report it as a mame or a mess bug.

Joined: Jan 2006
Posts: 3,690
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,690
I think the problem was related to LN's mistake on the MAME side, which got fixed in rev.25759
sync with latest and both MAME and UME should compile fine wink

Joined: May 2008
Posts: 4,930
Likes: 22
Q
Very Senior Member
Offline
Very Senior Member
Q
Joined: May 2008
Posts: 4,930
Likes: 22
Yeah, I can confirm that MAME, MESS and UME build fine on Linux using SVN r25769 smile.


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]
Joined: Aug 2012
Posts: 27
E
Member
Offline
Member
E
Joined: Aug 2012
Posts: 27
Successfully built 25770. Thank you for the info.

Joined: May 2012
Posts: 429
Likes: 1
R
Senior Member
Offline
Senior Member
R
Joined: May 2012
Posts: 429
Likes: 1
A fix for the cpc_flop softlist (cause CMP keep warning for similar names).

http://www.sendspace.com/file/ok63ch

(added a [a] to the second "carlos sainz #1 (nongoodcpc).dsk" )

Joined: Aug 2012
Posts: 74
Member
Offline
Member
Joined: Aug 2012
Posts: 74
Having trouble compiling ume on Ubuntu 13.10. After the directories are created I am presented with this:

Code:
No package 'QtGui' found
Compiling src/mame/drivers/rmhaihai.c...
Package QtGui was not found in the pkg-config search path.
Perhaps you should add the directory containing `QtGui.pc'
to the PKG_CONFIG_PATH environment variable

Joined: May 2008
Posts: 4,930
Likes: 22
Q
Very Senior Member
Offline
Very Senior Member
Q
Joined: May 2008
Posts: 4,930
Likes: 22
Install libqt4-dev and all its dependencies, then try again:

Code:
$ sudo apt-get install libqt4-dev


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]
Joined: Aug 2012
Posts: 74
Member
Offline
Member
Joined: Aug 2012
Posts: 74
That worked like a charm. Thanks!

Joined: Aug 2012
Posts: 74
Member
Offline
Member
Joined: Aug 2012
Posts: 74
Okay, so I'm having another compilation error, this time in
Windows 7 x64.
I invoked the following command:
Code:
make -j3 TARGET=UME ARCHOPTS=-march=native PTR64=1


Everything seemed fine and then I got the following error:
Code:
make (e=87): The parameter is incorrect.
make: *** [obj/windows64/UME/UME/liboptional.a] Error 87
make: *** Waiting for unfinished jobs....

Last edited by arcadefan; 03/08/14 01:48 AM.
Page 14 of 42 1 2 12 13 14 15 16 41 42

Link Copied to Clipboard
Who's Online Now
0 members (), 22 guests, and 0 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics9,086
Posts119,087
Members5,014
Most Online890
Jan 17th, 2020
Our Sponsor
These forums are sponsored by Superior Solitaire, an ad-free card game collection for macOS and iOS. Download it today!

Superior Solitaire
Forum hosted by www.retrogamesformac.com