Previous Thread
Next Thread
Print Thread
Page 1 of 6 1 2 3 4 5 6
MAME 0.152->0.153 : filters not working anymore ? #94188 05/05/14 07:15 AM
Joined: Dec 2007
Posts: 107
T
torturedutopian Offline OP
Senior Member
OP Offline
Senior Member
T
Joined: Dec 2007
Posts: 107
Hi everyone !

After building MAME 0.151 and 152 on my machine (with the hiscore patch ; Ubuntu 14.04 amd64) I did exactly the same thing to build MAME 0.153 ; all of a sudden, my filters are gone (CRT pixel shaders) while the mame.ini is correct. Any idea what may have gone wrong ?

Cheers ! & thanks again & sorry for bothering smile

Edit : to specify : I get no error on the command line and I tried without the hiscore patch too.

Last edited by torturedutopian; 05/05/14 07:41 AM.
Re: MAME 0.152->0.153 : filters not working anymore ? [Re: torturedutopian] #94189 05/05/14 11:59 AM
Joined: Mar 2001
Posts: 16,593
R
R. Belmont Online Content
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,593
Heh, yeah, I was kind of afraid that nobody following SVN used shaders.

Anyway, post the relevant chunk of your ini and some way to download the shaders and I'll see what I can do.

Re: MAME 0.152->0.153 : filters not working anymore ? [Re: torturedutopian] #94190 05/05/14 03:05 PM
Joined: Dec 2007
Posts: 107
T
torturedutopian Offline OP
Senior Member
OP Offline
Senior Member
T
Joined: Dec 2007
Posts: 107
Thanks a lot :-) If you want, I can follow the SVN in the future if it helps...

So : http://mahen.free.fr/temp/CRT.tar.gz

It's a version from 2011. I found a version from 2012 too but the screen curvature was incorrect for vertical games.

Code:
#
# OpenGL-SPECIFIC OPTIONS
#
filter                    1
prescale                  1
gl_forcepow2texture       0
gl_notexturerect          0
gl_vbo                    1
gl_pbo                    1
gl_glsl                   1
gl_glsl_filter            1
glsl_shader_mame0         /home/mahen/mame/glsl_plain
glsl_shader_mame1         /home/mahen/mame/CRT



Last edited by torturedutopian; 05/05/14 03:06 PM.
Re: MAME 0.152->0.153 : filters not working anymore ? [Re: torturedutopian] #94191 05/05/14 03:49 PM
Joined: Dec 2007
Posts: 107
T
torturedutopian Offline OP
Senior Member
OP Offline
Senior Member
T
Joined: Dec 2007
Posts: 107
(well, it seems there are curvature problems even with this ; do you have a better version by any chance ,)

Re: MAME 0.152->0.153 : filters not working anymore ? [Re: torturedutopian] #94192 05/05/14 04:01 PM
Joined: Jan 2006
Posts: 3,687
etabeta78 Offline
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,687
I cannot find anymore the shaders that I had around, unfortunately
(which is also why I had no way to test the latest changes until now frown )

Re: MAME 0.152->0.153 : filters not working anymore ? [Re: torturedutopian] #94193 05/05/14 10:35 PM
Joined: Jul 2007
Posts: 78
C
cgwg Offline
Member
Offline
Member
C
Joined: Jul 2007
Posts: 78
I really should set up a website for my shaders, but it probably won't happen.

Here's the older version and the most recent version. Note that the latter has several parameters tweakable in the file CRT-geom.vsh; in particular, the tilt angle which by default will tilt vertical games in a wrong direction.

Re: MAME 0.152->0.153 : filters not working anymore ? [Re: torturedutopian] #94197 05/06/14 07:18 AM
Joined: Dec 2007
Posts: 107
T
torturedutopian Offline OP
Senior Member
OP Offline
Senior Member
T
Joined: Dec 2007
Posts: 107
@cgwg : thanks, that's most appreciated ; those are the ones I had indeed ! I guess there is no way to fix the curvature angle issue apart from having 2 separate configurations ?

Meanwhile, I'll use the older one, I'm not sure to see the difference anyway smile

Last edited by torturedutopian; 05/06/14 07:22 AM.
Re: MAME 0.152->0.153 : filters not working anymore ? [Re: torturedutopian] #94198 05/06/14 07:35 AM
Joined: Dec 2007
Posts: 107
T
torturedutopian Offline OP
Senior Member
OP Offline
Senior Member
T
Joined: Dec 2007
Posts: 107
I know this is off topic (problem was MAME 0.153 shaders support) but do you guys enable the unevenstretch option ? I cannot make up my mind about this one...

Re: MAME 0.152->0.153 : filters not working anymore ? [Re: torturedutopian] #94199 05/06/14 12:03 PM
Joined: Mar 2001
Posts: 16,593
R
R. Belmont Online Content
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,593
It's kind of an intersection of personal taste and your output DPI. I run 1600x1200 on a 20" 4:3 monitor, and for that I don't think the unevenness is noticeable on most games. But if you're running a 15 kHz arcade monitor at 640x480 or 800x600 instead of doing custom modes, unevenstretch can definitely get pretty odd, especially on scrolling games.

Re: MAME 0.152->0.153 : filters not working anymore ? [Re: torturedutopian] #94202 05/06/14 09:01 PM
Joined: Dec 2007
Posts: 107
T
torturedutopian Offline OP
Senior Member
OP Offline
Senior Member
T
Joined: Dec 2007
Posts: 107
I use a 17" LCD in 1280x1024 so I think the only visible difference it makes is the fact a smaller picture will look sharper but sometimes the screen area difference is very small so I wonder if the extra screen area is worth the risk wink

Anyway, that's not that important !

Page 1 of 6 1 2 3 4 5 6

Moderated by  R. Belmont 

Who's Online Now
2 registered members (Golden Child, 1 invisible), 60 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,818
Posts116,101
Members4,915
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.3