Previous Thread
Next Thread
Print Thread
Console debugger "nil"s #116852 02/11/20 07:22 PM
Joined: Feb 2014
Posts: 363
G
Golden Child Offline OP
Senior Member
OP Offline
Senior Member
G
Joined: Feb 2014
Posts: 363
I haven't been keeping up to date with mame since 214 and I noticed that 219 doesn't echo debugger output to the console properly, instead printing a bunch of "nil"s.


I've grabbed the various mames from 215 to 219 and it seems to have started with 215.

Code
   _/      _/    _/_/    _/      _/  _/_/_/_/
   _/_/  _/_/  _/    _/  _/_/  _/_/  _/       
  _/  _/  _/  _/_/_/_/  _/  _/  _/  _/_/_/    
 _/      _/  _/    _/  _/      _/  _/         
_/      _/  _/    _/  _/      _/  _/_/_/_/    

mame 0.215	
Copyright (C) Nicola Salmoria and the MAME team

Lua 5.3	
Copyright (C) Lua.org, PUC-Rio

Debug Build: Disabling input grab for -debug
Debug Build: Disabling input grab for -debug
Debug Build: Disabling input grab for -debug
[MAME]> 

nil
nil
[MAME]> 

nil
[MAME]> 

nil
nil
[MAME]> 


Re: Console debugger "nil"s [Re: Golden Child] #116854 02/11/20 11:07 PM
Joined: Jan 2012
Posts: 819
C
crazyc Offline
Senior Member
Offline
Senior Member
C
Joined: Jan 2012
Posts: 819
Fixed in https://github.com/mamedev/mame/commit/a0a658a11148f3dac497d24a3eb16460df9b69c0. Seems index metamethod doesn't work properly with sol2 simple usertype.

Re: Console debugger "nil"s [Re: crazyc] #116858 02/12/20 01:06 PM
Joined: Feb 2014
Posts: 363
G
Golden Child Offline OP
Senior Member
OP Offline
Senior Member
G
Joined: Feb 2014
Posts: 363
Thanks, crazyc!


Who's Online Now
2 registered members (Pernod, Praxis), 174 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,749
Posts114,947
Members4,884
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.3