Replying to myself because... it works! I found the Option corresponding to the -numscreens 3 argument and put back to the default of 1. No idea why it was set at 3. I can only assume that in the past, my mouse cursor was hovering over that control when I scroll-wheeled up, expecting the window to scroll up!
I wonder if that explains the command line bloom_overdrive and joystick arguments that I don't remember ever specifying in the Options.