in qmc2 settings i enable bgfx and d3d for old crt effect smile
from video menu change or bgfx or d3d.
i dont know why show "-video bgfx" settings if enable d3d mode.

What does the emulator log say why it returns 6?
dont know, but now not starting any game.

btw - now compiling the last mame git and try again,
result after 20-30min

no, same history, qmc2 dont start any game
test with mame:
Git SHA-1 : c2c22570779f69e6921499b7abeb75f6db3d7822
Revision : 42895


Rene, removed all qmc2 seetings folders, cashes
absolutly clean qmc2 :
config only path to mame executables and path to mame roms.

examples : start pang , game not starting , see log:

Code:
17:18:48.536: M.A.M.E. Catalog / Launcher II v0.63, SVN r7510 (Qt 4.8.6, MAME, Windows x86_64-w64-mingw32)
17:18:48.537: Phonon features enabled - using Phonon v4.4.0
17:18:48.537: SDL joystick support enabled - using SDL v2.0.3
17:18:48.538: processing global emulator configuration
17:18:48.538: creating template configuration map
17:18:48.539: template info: emulator = MAME, version = 0.172, format = 0.2.8
17:18:48.836: determining emulator version and supported sets
17:18:48.920: image cache size set to 64 MB
17:18:48.969: shortcut map is clean
17:18:48.970: joystick map is clean
17:18:49.010: please reload machine list for some changes to take effect
17:18:49.010: creating template configuration map
17:18:49.011: template info: emulator = MAME, version = 0.172, format = 0.2.8
17:18:49.709: done (determining emulator version and supported sets, elapsed time = 00:00.873)
17:18:49.710: emulator info: type = MAME, version = 0.172
17:18:49.710: 33429 supported (non-device) sets
17:18:49.711: loading XML data and recreating cache
17:21:00.764: done (loading XML data and recreating cache, elapsed time = 02:11.053)
17:21:00.771: WARNING: can't open ROM state cache, please check ROMs
17:21:00.772: processing machine list
17:21:00.774: pre-caching icons from directory
17:21:01.149: done (pre-caching icons from directory, elapsed time = 00:00.375)
17:21:01.150: 0 icons loaded
17:21:01.150: parsing machine data and recreating machine list cache
17:21:14.800: sorting machine list by machine description in ascending order
17:21:15.080: done (processing machine list, elapsed time = 00:14.308)
17:21:15.081: 33360 machines, 69 BIOS sets and 3025 devices loaded
17:21:15.081: ROM state info: L:36454 C:? M:? I:? N:? U:36454
17:21:15.093: loading favorites and play history
17:21:15.094: done (loading favorites and play history)
17:21:15.094: total start-up time: 02:26.558
17:21:22.373: starting emulator #0, command = G:\M.A.М.Е\mame64.exe -rompath "g:\MAME\Mame_ROMs" -window -nomaximize -keepaspect -rotate -noror -norol pang
17:21:22.479: emulator #0 started, PID = 224138048, running emulators = 1
17:21:22.735: embedding emulator #0, window ID = 0x5085c
17:21:22.980: emulator #0 embedded, window ID = 0x5085c
17:21:28.015: window ID for emulator #0 lost, looking for replacement
17:21:28.031: WARNING: emulator #0 crashed
17:21:28.031: emulator #0 finished, exit code = -1073740940 (unknown error), exit status = crashed, remaining emulators = 0
17:21:28.032: no replacement window ID found for emulator #0, closing embedder
17:21:36.262: starting emulator #1, command = G:\M.A.М.Е\mame64.exe -rompath "g:\MAME\Mame_ROMs" -window -nomaximize -keepaspect -rotate -noror -norol pang
17:21:36.300: emulator #1 started, PID = 268267712, running emulators = 1
17:21:36.550: embedding emulator #1, window ID = 0x6085a
17:21:36.641: emulator #1 embedded, window ID = 0x6085a
17:21:37.167: window ID for emulator #1 lost, looking for replacement
17:21:37.169: WARNING: emulator #1 crashed
17:21:37.170: emulator #1 finished, exit code = -1073740940 (unknown error), exit status = crashed, remaining emulators = 0
17:21:37.170: no replacement window ID found for emulator #1, closing embedder
17:21:43.182: starting emulator #2, command = G:\M.A.М.Е\mame64.exe -rompath "g:\MAME\Mame_ROMs" pang
17:21:43.252: emulator #2 started, PID = 266784512, running emulators = 1
17:21:46.373: WARNING: emulator #2 crashed
17:21:46.373: emulator #2 finished, exit code = -1073740940 (unknown error), exit status = crashed, remaining emulators = 0


btw - with MameUI all it's fine.

Last edited by oddi; 04/24/16 02:24 PM.