Back when Moogly first added BGFX shader support I was sort of keeping up with things.

I could write and compile shaders and everything was fine. Sometimes shader compilation would break for one or more backends when BGFX (the third party stuff, not MAME) was brought in, but it usually went away with the next BGFX update.

But I was working a full-time job and another 66%-time teaching job and stopped paying attention for a couple months.

Anyway, I can't compile shaders or bgfx-tools, with the official dev tools now.

Specifically, I get errors compiling shaderc at first. Then, after solving this (or attempting to) by manually running some commands involving flex/bison that I have no idea what they do, I can get a little further. I end up at a command prompt (cmd.exe not bash) that the bash shell opened with nothing going on.

That's also what I get if I just head into the mame/src/osd/modules/render/bgfx/shaders folder and try to compile the shaders from there. Which also used to work but doesn't now.

I don't know if it's just some makefile nonsense, some kind of path/package issue, or something else. But at the end of the day, I can't compile the shaders/bgfx-tools in Win7 or Win10 on a couple different PCs with either freshly downloaded or updated dev tools.

My guess is that something broke awhile back in the 3rd party bgfx section and that nobody noticed because (1)shaders aren't compiled very often (2)people don't use windows (3)you still have old working compiled bgfx tools in your environment so you don't see the breakage.

Any ideas on how to get this working again?