It's quite possible there's an incompatibility with 2.0.8, I'll investigate. Thanks for tracking it down!