In a previous thread I reported that mame 0.215 was crashing immediately with bgfx enabled.

I compiled the latest git to find that issue was resolved... as long as I use metal as the backend. OpenGL only uses ¼ of the monitor with a Retina display.

However I am finding a lot of older games show a mostly red screen. This is dkong, I've seen it with mario, centiped, polepos, phoenix, etc.

[img]https://photos.app.goo.gl/iZ3PSKJ55cnv6mVM8[/img]

I remembered that SDL supports -video accel and that works fine, as does -video soft.

However I cannot seem to select video accel in the mame.ini file as it seems to fall back to bgfx. Is there anyway to default to accel or will I have to type the command every time?
I seem to recall before bgfx came along that you could choose soft, OpenGL, or accel as options for video in the .ini file.

thanks!


=will=