I'm not really in a position to isolate/fix this before the next release, but assuming you're on a Mac, can you please test to see if it's a locale issue again. I can't give you precise instructions because Apple moves stuff around on every release:
  • Create a new user account so you don't mess up settings on your current one
  • Put a complete MAME folder somewhere accessible by the new user account
  • Open System Preferences or its localised equivalent
  • Select Language & Region or its localised equivalent
  • Get the number format settings up - it may be a tab, or you may have to click an Advanced… button
  • Change all the number formats to English, and ensure the grouping separator is a comma ',' and the decimal separator is a dot '.'
  • Do the needful to save the settings and close System Preferences
  • Try running MAME again


It really shouldn't be a locale issue this time, but it's worth a shot given how many other times that's been it. But if it isn't you're going to have to isolate whatever causes it before someone can fix it.