It's something I haven't tried either 8-)

I've never tried running two instances of mame before. It seemed to work ok, though I was running both out of the same directory, but starting with different terminal windows.

After doing some reading, I tried this:

running one instance of mame with:

./mame votrtnt -rs232 null_modem -bitbanger

and then running another instance with:

./mame apple2e -sl2 ssc -sl2:ssc:rs232 null_modem -bitbanger

and typing PR#2
and then typing things.

I could hear it saying like SYNTAX ERROR sounds like "SYNAXER"

Also you should be able to connect directly to the serial port to real hardware:

(I had to do

sudo usermod -a -G dialout ${USER}
sudo usermod -a -G tty ${USER}

to allow mame to directly connect to the serial port under Ubuntu)

./mame apple2e -sl2 ssc -sl2:ssc:rs232 null_modem -bitbanger /dev/ttyS0


./mame votrtnt -rs232 null_modem -bitbanger /dev/ttyS0

I would imagine that under windows you'd just put COM1 or whatever COM port you're using in place of /dev/ttyS0

This makes me wanna get out some serial hardware to have mame talk to real hardware!

I'm gonna have to read the manual, looks pretty cool:

I remember how much fun I had with the Amiga's narrator.device and had it saying "Take a break, dood" 8-)
Now I have this as my compile command under ubuntu where it uses spd-say to tell me the compile's done:
alias mmake='make CFLAGS="-U_FORTIFY_SOURCE" ';t0=`date +%s`;time  mmake -j4 regenie=1 TOOLS=1; t1=`date +%s`;notify-send "mame compile" "compile done in $(($t1-$t0))"; spd-say "compile, done in $(($t1-$t0))"