You need to put the -rs232 option after the system name.