Thank you for posting this.

I have a question/problem (A Black (blank) Screen). Note: I am working under the premise that entering ./mame64 from the applicable directory should be enough to see MAME's menu.

Note for admin - as this issue is resolved mostly, it may help others but if this issue is already covered and my post is out of place, feel free to delete it. Thanks for understanding.

If this is not the ideal thread to post this please let me know and I will repost in whichever forum room you recommend.

Mac OS High Sierra 10.13.6
mame0226-64bit (downloaded from
SDL 2.0 (Installed in /Library/Frameworks)
MacPorts not in use as I am afraid it may conflict with brew

Mac Restarted after SDL install
From the command line (terminal), navigated to the folder containing the mame64
uploaded one ROM to the roms folder
tried ./mame64 (a blank screen appears)
tried ./mame64 -createconfig (created a mame.ini file)
tried ./mame64 -video accel (a blank screen appears)
tried ./mame64 -video opengl (a blank screen appears)
tried ./mame64 [with no files in roms folder (a blank screen appears)

For some reason my ESC appears defective - just discovered so when I get the blank screen I use command-H to hide the mame64 executable followed by a force quit of the executable from the dock.

I have some very old notes that I wrote some time ago to help me with version mame0205-64bit so I installed it because my old notes suggest it did work. I launched mame64 (version 0205-64bit) but there is only one change from what happens with mame0226-64bit, I see a 1 pixel wide white frame that wraps around the screen and displays for about 1 second and then the screen goes black.

I also tried, as a test, NOTE: I am not concerned about a ROM not executing.
./mame64 /Volumes/4TB\ Internal/ORGANIZED/Emulation/mame0226-64bit/roms\ old/arabian.7z
ic1rev2.87 NOT FOUND (tried in arabian)
ic2rev2.88 NOT FOUND (tried in arabian)
ic3rev2.89 NOT FOUND (tried in arabian)
ic4rev2.90 NOT FOUND (tried in arabian)
tvg-91.ic84 NOT FOUND (tried in arabian)
tvg-92.ic85 NOT FOUND (tried in arabian)
tvg-93.ic86 NOT FOUND (tried in arabian)
tvg-94.ic87 NOT FOUND (tried in arabian)
sun-8212.ic3 NOT FOUND (tried in arabian)
Fatal error: Required files are missing, the machine cannot be run.

So MAME appears to be working to some extent.

Some progress

I tried ./mame64 -debug -log > log.txt
For some reason, two terminal windows appear, one is all blank (black) and the second one has the mame menu. I am surprised that the -debug flag doesn't go full screen which helped me locate the problem as two windows show up, not full screen. Interestingly, the -debug flag also results in two exec icons visible from the dock.

I guess this is resolved to some extent. I will continue to explore.

Last edited by AlexS; 02/12/22 06:35 PM.