I saw it mentioned that you can’t play The Immortal because it doesn’t like seeing keystrokes. What if you go to the Keyboard Selection menu and disable the keyboard until it’s ready to accept keyboard input?