I’m not overly familiar with the Mac drivers, so I’m not sure if this is me doing something wrong, known limitations, or bugs.

If I try running Mac II booted from a hard disk with two hard disks connected, ADB locks up after the desktop appears. For example if I use this command, the mouse/keyboard won’t respond after the desktop appears:
Code
mamed macii -ui_active -nb9 spec8s3 -hard1 mac711 -scsi:2 harddisk -hard2 SuperMac.hdv

However, if I boot from a floppy, I can browse both hard disks and copy files between them without ADB locking up. For example, this works:
Code
mamed macii -ui_active -nb9 spec8s3 -hard1 mac711 -scsi:2 harddisk -hard2 SuperMac.hdv -flop mac_flop:sys608

I occasionally get stuck keys, so I guess this is just ADB HLE weirdness?

Weirder than that though is that System 7.1 doesn’t see some files on the hard disk while System 6 does.

With that previous command (booting from System 6.0.8 on floppy with the System 7.1.1 Pro hard disk attached), I can see the PowerTalk Folder, System 7 Pro Read Me folder, TeachText, etc. as well as any other stuff I add myself.

However, if I boot from System 7 itself, I only see the System Folder in the root folder of the hard disk. For example this only shows the System Folder:
Code
mamed macii -ui_active -nb9 spec8s3 -hard1 mac711

I tried rebuilding the desktop file on the hard disk, but it didn’t improve the situation.

This was all with debug builds, I haven’t tried a release build. Is there something I’m doing wrong?