Originally Posted By Hoop2004

To test I tried tempest version 3 and metalslug3.


As RB said, you need the Neo Geo BIOS ROM to run Neo Geo games.

Tempest rev. 3 is the parent set of Tempest these days, so the archive you got must be outdated.

To view an up-to-date list of required files for each game, go here:
www.mameworld.net/maws