Duh.

Prescale must be set to 1. I never use glsl and didn't think of prescale until I set glsl 1 and got the "OpenGL: GLSL supported, but disabled due to: prescale !=1" message.

So I now have full screen LD output, although a bit choppy.

Thanks to everyone for your help.