After some searching, it appears that the scrambled PCM was simply an error in the k007232 emulation of the 129u4 build, had nothing to do with the hack itself.

I tried the binary on three different computers under the assumption that the problem was due to some property of my computer in particular, but I got the same result. So I must be doing something wrong, although I have no clue what it might be.

Maybe I'm overlooking something stupid... I'm placing the downloaded binary.exe in D:\gra3\mame, placing Rom zips in D:\gra3\mame\roms, double-clicking the exe, then selecting a game from the menu that appears. Aside from the aforementioned scrambled PCM, everything seems to work as expected for Mame. The game runs, the FM sound plays just fine, it's only the hack's added features don't seem to work. Keys 0-8 have no effect on the FM sound, and key 9 creates a gamename.opm that is 0kb and totally empty.

Also recently, Windows has apparently taken to disliking the binary, because after running it once, it wants nothing to do with it... won't run it again, won't let me move it, delete it, check its properties, etc... Explorer just freezes up when I try to do so. It keeps that up until after I reset. It wasn't doing that at first, I don't know what it's about.