First of all, thank you again for taking the time!

Thought so about the FPS counter. Thanks for confirming that.

Good to know the log indicates I do have an HPET. I know Windows Vista was the first Windows consumer OS to support it, so its presence in the system devices was no surprise. "No drivers are installed for this device" therefore does not mean its absence, does it? Various forums suggested otherwise, so please excuse my misconception. Since you're a Windows developer, I clearly trust your knowledge more smile
What's sad is that even relying on HPET and not D3D's multimedia timer does not fix this. Please realize that I've, by now, tried every type of configuration I could think of. I'm not stuck in the above.

I know about the resolution and I know about the limitations of the human ear. Pay no mind to either values, as they do not appear to matter in the slightest concerning this problem (well, here they don't). Please think back to my previous posts: I've already tried numerous resolutions (16 and 32 bit) and numerous sampling rates; every option present. I stated twice that I aligned them with my playback device's set sampling rate, so Windows would not have to do software resampling (which I, too, know about wink ). I was merely trying different things out. I'm sorry for the confusion.

As for the refresh rate, please look here: http://support.microsoft.com/kb/2006076/
Then here: http://www.sevenforums.com/tutorials/33641-screen-refresh-rate-custom-nvidia-brand.html
As I stated before, this has been by design since Vista and is a known "problem". It is more accurate than what XP was doing (rounding up), but it causes issues with VSync in quite a number of even recent games (Modern Warfare, for one), because they're apparently badly coded: Their VSync expectation of 60 Hz seems to be hardcoded into them, so supplying any other frequency results in stuttering. Setting it to 60.001 Hz in the NV control applet fixes that. My monitor is an HP LP2475w. I've got its 2.0.0.0 drivers installed via Windows Update.
Yet again, as I mentioned before, supplying other frequencies to Nestopia for VSyncing does nothing to fix its audio stuttering. I apologize if I seem patronizing. As a Windows dev, you might know all this already.

Edit: One more thing: Forcing the maximum pre-rendered frames option up or down in the NV driver applet does nothing to fix this as well and neither does forcing Nestopia to use only a single GPU.

I qualified my XP statement (I used another computer altogether), so I believe I reigned in my initial generalization. Please take it as just another observation. That was an old machine: Athlon 64 3500+, MSI K8N Neo4 Platinum, Geforce 7800 GT, 1GB DDR2 RAM. I used XP SP3. My Nestopia configuration was the same, though with a lower sampling rate (44100 Hz) and my old monitor's native resolution (12801024). I've tried those in Win7 on this new machine and they don't fix it.
Please bear with me, I'm just supplying you with information here smile

I'll e-mail you an MP3 right away.

Edit: And I did, but for any other people having this issue and wanting to confirm that it's indeed theirs as well, here's a download link: http://www.sendspace.com/file/wlqyqp
It was done with "synchronize to refresh rate" set, VSync and triple buffering on, sound latency set to "1" and in window mode. Fullscreen is the same. My monitor refresh rate was forced to 60.001 Hz. Changing that back to default or other values near or precisely 60 Hz has no effect here. "Use high precision timer" is set as well, but disabling it had no effect, too. My recording software is Audacity.
If anyone else wants to chime in, please feel welcome. Maybe you can provide c0d3h4x0r with some more info he might need smile

Last edited by gummybear; 04/12/10 01:53 PM.