ok... ive been at this for days, scouring the net, googling everything
trying out everything i have read about....
Im using MAME OSX 0.135 on an iBOOK G4 OSX 10.4.11(power pc g4 1.1)
struggling to get Streetfighter 3 to work to little avail....
initially "missing files blah blah"
so i hunted and found

tried again, no go.... then i downloaded all the versions of sf3 i could find
put the missing files in each of them, actually-each sf3 zip has all the diff version files in each.... and rezipped into the roms folder... (someone did this and it worked)
i put the chd files into the hard disk images file also, unzipped...
then i redirected mame to my roms folder..... as i saw someone do that
tried each of them again...no go

i saw something on youtube, the guy put the bin file zipped and japan no cd file zipped in the roms folder, as well as a reg folder with all the sf3 files unzipped
into the roms folder as well...
i also have the neogeo bios(though it might be an older one)
i found the hyper neogeo 64 bios, and uni-bios-23
maybe i need the japan no cd bios- not sure if thats the one included in the rom?
after all this i audited my roms, and nothing came up

i can now get streetfighter 3 to start,
"there are known problems with this game"
and initially with a "missing/incorrect rom" statement
tho i just tried again, and that didnt come up. but the known probs statement does, in a yellow window.....

the game runs, but its stuttering badly, running less than half speed
im guessing its a frames per second issue....
and another USA version opens at a Cps3 screen, and asks me if i want to rewrite the game, will take 70 mins...i dont know what that means so i havent tried...

i have also come across the mention of the need for NVRAM files, but i havent found much more info pertaining to that

i dont know if my problems are older ROM copies (ive tried to use newer releases)
i also noticed some of the files (10,20,30,31,40,41,50,51,60,61), in some ROM folders were 'document files', i made sure to have all 'unix executable files' instead, have no idea if that makes a diff?
or if its something that has been renamed by MAME in an update of ROM names?,
or if my computer not being Intel is an issue? it is a few years old...sigh*

also trying to play samurai showdown on MAME OSX- files missing log...
and the neo geo bios is recognized, but it says looking for: (this), but found: (that)
so i dont know how to fix that either.... as samurai showdown 2,3,and 4 work fine on MACMAME with the neogeo bios i have, but not on MAME OSX, although samurai showdown 5 is another issue, it doesnt show up on MACMAME, or MAME OSX.... but i havent fussed with those as much as streetfighter, so i dont know...
i still have to find all the missing files, and rezip all concerned again..yadda yadda.

at this point im considering trying out SDLMAME, or even a windows emulator, and run a windows MAME on that...!!! i wont give up though,
im still hoping to play Streetfighter 3 online, but i read u cant do that on MAME OSX, but on Windows MAME instead, with something called Kaillera... digging around through all this shows me i have ALOT to learn.

sorry for the long post, but i would really appreciate some help
Ive tried to be as thorough as possible, hope its nothing stupid i missed
thanks for reading through all this...take care!!