I still have the input lag when vsync is enabled. It's a little bit better, but I still can notice it in Mike Tyson's Punch Out - it's enough to affect the gameplay. My specs:

Windows 7 x64
ATI 5850 with latest CATs installed
Core i7
4GB of RAM
Resolution at 1280x720 @ 60Hz

Synchronize to Refresh Rate
Use high-precision timer
Enable triple buffering
Default speed

I'm using a Logitech Rumblepad 2 if that makes any difference. Disabling vsync resolves the input lag, but I get screen tearing of course.

Last edited by BuddMan; 07/08/10 02:49 AM.