Gah. In the forum move I forgot to turn on e-mail verification. I've done so now...