Regarding sound latency: Things to try, one at a time:

* Options->Sound -- Adjust the Latency slider (increase it or decrease it one notch). It sounds like you've already tried this though.
* Options->Video -- Turn off High Precision Timer
* Options->Video -- Turn off Triple Buffering
* Options->Video -- Disable Vsync

You may need to try all the combinations of these to find something that works. I'm familiar with XP, not Windows 7. I also use an SB Audigy series card in my system w/out any audio skipping (Latency slider is set to 2), but again, I use XP. Windows 7's audio layer is *significantly* different, and this isn't just tech forum l33tg4m3rd00d nonsense I'm stating.

Last edited by koitsu; 01/14/11 06:37 AM.

Making life hard for others since 1977.