Bringing this post over from
Ran APPLE2GS driver, set up some slot devices, then hit RESET at the bottom of the same menu. Got an "Initializing..." screen that hung for a bit, then dumped me out with a stack trace.

Average speed: 98.93% (18 seconds)
0000000000228260: 0000000000C94C57 (winmain_dump_stack()+0x0037)
0000000000228320: 000000000163CAA1 (fatalerror(char const*, ...)+0x00d1)
0000000000228470: 000000000128E759 (save_manager::save_memory(char const*, char const*, unsigned int, char const*, void*, unsigned int, unsigned int)+0x0449)
0000000000228500: 0000000000B2152D (applefdc_start(device_t*, applefdc_t)+0x011d)
0000000000228540: 00000000012ECA88 (legacy_device_base::device_start()+0x0028)

00000000002286C0: 000000000124E152 (device_t::start()+0x0272)
0000000000228860: 0000000001278346 (running_machine::start_all_devices()+0x0136)
0000000000228AD0: 0000000001278F2B (running_machine::start()+0x098b)
0000000000228CC0: 0000000001279943 (running_machine::run(bool)+0x0323)
000000000022F430: 0000000001182EA3 (mame_execute(emu_options&, osd_interface&)+0x0543)
000000000022F8D0: 00000000013CD03E (cli_frontend::execute(int, char**)+0x0d5e)

000000000022FE10: 0000000000C92E1E (utf8_main(int, char**)+0x047e)
000000000022FE60: 000000000161BC1C (wmain+0x006c)
000000000022FF20: 00000000004013E2 (__tmainCRTStartup+0x0262)
000000000022FF50: 00000000004014E8 (mainCRTStartup+0x0018)
000000000022FF80: 0000000076FB652D (BaseThreadInitThunk+0x000d)
000000000022FFD0: 000000007755C521 (RtlUserThreadStart+0x0021)
Duplicate save state registration entry (applefdc/0/fdc->write_byte)