MAME will be compatible with it ASAP, but it's going to take time for it to filter out and for people to find the worst of the bugs and so 1.2.15 will remain the supported default. (In particular, I'm not expecting Linux distros to have their act completely together on this until November-ish when Fedora 20 and the next Ubuntu both are due).